summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Viallon2021-02-09 13:43:23 +0100
committerAntoine Viallon2021-02-09 13:43:23 +0100
commit8589dbf852af7f749ee7a27547efb401b209eb5b (patch)
treed64c595c635826de227f0980286d2d7e54576700 /PKGBUILD
parentc3e719999ccc2bb3ce6f3bca61c181965166fd83 (diff)
downloadaur-z88dk-git.tar.gz
Change pkgver function, add missing submodules and disable automatic ccache
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 33 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 181aed25673d..55b275a8cdf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Maintainer: Jan Baudisch <dev@baudisch.xyz>
+# Maintainer: Antoien Viallon <antoine+aur@lesviallon.fr>
+# Contributor: Jan Baudisch <dev@baudisch.xyz>
pkgname=z88dk-git
-pkgver=de7d7119a
+pkgver=v2.1.r19.g7c6df7ac3
pkgrel=1
pkgdesc="The development kit for over fifty z80 machines - c compiler, assembler, linker, libraries."
arch=("x86_64")
@@ -11,32 +12,50 @@ provides=("z88dk")
conflicts=("z88dk")
source=("$pkgname::git+https://github.com/z88dk/z88dk.git"
"z88dk.sh"
- "unixem::git+https://github.com/z88dk/UNIXem.git"
+ "0001-disable-forced-ccache.patch"
+ "UNIXem::git+https://github.com/z88dk/UNIXem.git"
+ "Unity::git+https://github.com/ThrowTheSwitch/Unity.git"
+ "cpm::git+https://github.com/z88dk/cpm.git"
"optparse::git+https://github.com/skeeto/optparse.git"
- "uthash::git+https://github.com/z88dk/uthash.git")
-sha256sums=("SKIP"
- "d9e302908dd3355440901254c48ffa43af273ec710ce442db77406c378f1942d"
- "SKIP"
- "SKIP"
- "SKIP")
+ "regex::git+https://github.com/geoffmcl/regex.git"
+ "uthash::git+https://github.com/z88dk/uthash.git"
+ )
+
+sha256sums=('SKIP'
+ '0474d26668224231cffeaef33776020ee65fe83c825833c9907e4766d9104869'
+ 'f785924a5e0e10f327408ad1362f2923a1684f58e66af715c21f8469a5bbaa1a'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "$pkgname"
- git rev-parse --short HEAD
+ # cutting off 'foo-' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "$pkgname"
git submodule init
- git config submodule.UNIXem.url $srcdir/unixem
- git config submodule.optparse.url $srcdir/optparse
- git config submodule.uthash.url $srcdir/uthash
- git submodule update
+ _submodules=(UNIXem Unity cpm optparse regex uthash)
+ for submodule in ${_submodules[@]}; do
+ git config submodule.${submodule}.url "$srcdir/${submodule}"
+ done
+ git submodule update --recursive
+
+ for patch in $(cd "$srcdir" && ls *.patch); do
+ echo "Applying patch '$patch'..."
+ patch -d "$srcdir/$pkgname" -i "$srcdir/"${patch}
+ done
}
build() {
cd "$pkgname"
chmod +x build.sh
+ export CFLAGS="$CFLAGS -Wno-unused-value -Wno-unused-result"
./build.sh
}