summarylogtreecommitdiffstats
path: root/Wno-array-bounds-gtest.patch
diff options
context:
space:
mode:
authorZiusudra2022-12-04 23:04:10 -0700
committerZiusudra2022-12-04 23:04:10 -0700
commitaae247126e1cd6b3c96dae5c078bca6103833dc8 (patch)
treecc828d93b7975650fa831141e184f65e93270949 /Wno-array-bounds-gtest.patch
parentbae742b2b4ba6470b0010cf4520b78f55907f7f7 (diff)
downloadaur-dfhack.tar.gz
dfhack-0.47.05-r8 +updated patches
Diffstat (limited to 'Wno-array-bounds-gtest.patch')
-rw-r--r--Wno-array-bounds-gtest.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/Wno-array-bounds-gtest.patch b/Wno-array-bounds-gtest.patch
new file mode 100644
index 000000000000..6baa61efa06a
--- /dev/null
+++ b/Wno-array-bounds-gtest.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text dfhack/depends/CMakeLists.txt dfhack.new/depends/CMakeLists.txt
+--- dfhack/depends/CMakeLists.txt 2022-12-02 22:34:28.530386074 -0700
++++ dfhack.new/depends/CMakeLists.txt 2022-12-03 21:32:03.853149929 -0700
+@@ -8,7 +8,7 @@
+ option(INSTALL_GTEST "Enable installation of googletest. (Projects embedding googletest may want to turn this OFF.)" OFF)
+ add_subdirectory(googletest)
+ if(UNIX)
+- set_target_properties(gtest PROPERTIES COMPILE_FLAGS "-Wno-maybe-uninitialized -Wno-sign-compare")
++ set_target_properties(gtest PROPERTIES COMPILE_FLAGS "-Wno-maybe-uninitialized -Wno-sign-compare -Wno-array-bounds")
+ endif()
+ endif()
+