summarylogtreecommitdiffstats
path: root/Wno-restrict-modules.patch
diff options
context:
space:
mode:
authorZiusudra2022-12-04 23:04:10 -0700
committerZiusudra2022-12-04 23:04:10 -0700
commitaae247126e1cd6b3c96dae5c078bca6103833dc8 (patch)
treecc828d93b7975650fa831141e184f65e93270949 /Wno-restrict-modules.patch
parentbae742b2b4ba6470b0010cf4520b78f55907f7f7 (diff)
downloadaur-dfhack.tar.gz
dfhack-0.47.05-r8 +updated patches
Diffstat (limited to 'Wno-restrict-modules.patch')
-rw-r--r--Wno-restrict-modules.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/Wno-restrict-modules.patch b/Wno-restrict-modules.patch
new file mode 100644
index 000000000000..4e806e480737
--- /dev/null
+++ b/Wno-restrict-modules.patch
@@ -0,0 +1,11 @@
+diff --unified --recursive --text dfhack/library/CMakeLists.txt dfhack.new/library/CMakeLists.txt
+--- dfhack/library/CMakeLists.txt 2022-12-04 00:58:10.697225422 -0700
++++ dfhack.new/library/CMakeLists.txt 2022-12-04 01:16:14.329282824 -0700
+@@ -208,6 +208,7 @@
+ list(APPEND PROJECT_SOURCES ${MAIN_SOURCES_DARWIN})
+ else()
+ list(APPEND PROJECT_SOURCES ${MAIN_SOURCES_LINUX})
++ set_source_files_properties(${MODULE_SOURCES} PROPERTIES COMPILE_FLAGS "-Wno-restrict")
+ endif()
+ elseif(WIN32)
+ list(APPEND PROJECT_SOURCES ${MAIN_SOURCES_WINDOWS})