summarylogtreecommitdiffstats
path: root/bloaty-no-bundled-sources.patch
diff options
context:
space:
mode:
authorAdrian Perez de Castro2024-03-17 23:59:38 +0200
committerAdrian Perez de Castro2024-03-18 00:00:04 +0200
commit9102eb45a0196fb9a7640a8f50e4f851ee10a5c9 (patch)
tree0686e1f1ee3b15db5d2ac60ae461d5a3526ee64c /bloaty-no-bundled-sources.patch
parent94ceb09274fa75f2649398e1b5de319514080989 (diff)
downloadaur-bloaty-git.tar.gz
Fix the build, use system abseil-cpp package
Diffstat (limited to 'bloaty-no-bundled-sources.patch')
-rw-r--r--bloaty-no-bundled-sources.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/bloaty-no-bundled-sources.patch b/bloaty-no-bundled-sources.patch
new file mode 100644
index 000000000000..d6dfd7405d8b
--- /dev/null
+++ b/bloaty-no-bundled-sources.patch
@@ -0,0 +1,53 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5a843b9..7337a22 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -58,11 +58,6 @@ if(NOT CMAKE_BUILD_TYPE)
+ FORCE)
+ endif()
+
+-# Check out Git submodules.
+-if (EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/.gitmodules")
+- execute_process (COMMAND git submodule update --init --recursive
+- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR})
+-endif()
+
+ # Add third_party libraries, disabling as much as we can of their builds.
+
+@@ -157,7 +152,6 @@ endif()
+
+ include_directories(.)
+ include_directories(src)
+-include_directories(third_party/abseil-cpp)
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}/src")
+
+ # Baseline build flags.
+@@ -244,28 +238,6 @@ add_library(libbloaty STATIC
+ src/util.cc
+ src/util.h
+ src/webassembly.cc
+- # Until Abseil has a proper CMake build system
+- third_party/abseil-cpp/absl/base/internal/raw_logging.cc # Grrrr...
+- third_party/abseil-cpp/absl/base/internal/throw_delegate.cc
+- third_party/abseil-cpp/absl/debugging/internal/demangle.cc
+- third_party/abseil-cpp/absl/numeric/int128.cc
+- third_party/abseil-cpp/absl/strings/ascii.cc
+- third_party/abseil-cpp/absl/strings/charconv.cc
+- third_party/abseil-cpp/absl/strings/escaping.cc
+- third_party/abseil-cpp/absl/strings/internal/charconv_bigint.cc
+- third_party/abseil-cpp/absl/strings/internal/charconv_parse.cc
+- third_party/abseil-cpp/absl/strings/internal/escaping.cc
+- third_party/abseil-cpp/absl/strings/internal/memutil.cc
+- third_party/abseil-cpp/absl/strings/internal/utf8.cc
+- third_party/abseil-cpp/absl/strings/match.cc
+- third_party/abseil-cpp/absl/strings/numbers.cc
+- third_party/abseil-cpp/absl/strings/str_cat.cc
+- third_party/abseil-cpp/absl/strings/string_view.cc
+- third_party/abseil-cpp/absl/strings/str_split.cc
+- third_party/abseil-cpp/absl/strings/substitute.cc
+- third_party/abseil-cpp/absl/types/bad_optional_access.cc
+- # One source file, no special build system needed.
+- third_party/demumble/third_party/libcxxabi/cxa_demangle.cpp
+ )
+ set_property(TARGET libbloaty PROPERTY FOLDER "bloaty")
+