summarylogtreecommitdiffstats
path: root/cmake-threadlib.patch
diff options
context:
space:
mode:
authorTomas Kirnak2023-08-31 03:30:05 +0200
committerTomas Kirnak2023-08-31 03:32:07 +0200
commitd5efa5e1e5e9c33e6920c829d82aff91d7596be6 (patch)
tree0da3f513944d686f024834adac7da4c8bc22bbc4 /cmake-threadlib.patch
parent30cbd86ebe67438df5f4037dde31a0b810479b9f (diff)
downloadaur-shrew-vpn-client.tar.gz
Fixed package build failing, backported from the main "ike" package
Diffstat (limited to 'cmake-threadlib.patch')
-rw-r--r--cmake-threadlib.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/cmake-threadlib.patch b/cmake-threadlib.patch
new file mode 100644
index 000000000000..323e049ff90b
--- /dev/null
+++ b/cmake-threadlib.patch
@@ -0,0 +1,28 @@
+diff --unified --recursive --text --color package.orig/ike/CMakeLists.txt package.new/ike/CMakeLists.txt
+--- a/CMakeLists.txt 2022-04-04 14:41:54.512667837 -0500
++++ b/CMakeLists.txt 2022-04-04 14:42:13.302667617 -0500
+@@ -321,15 +321,15 @@
+
+ endif( NOT CMAKE_USE_PTHREADS_INIT )
+
+-if( NOT APPLE )
+-
+- check_library_exists(
+- ${CMAKE_THREAD_LIBS_INIT}
+- "pthread_mutex_timedlock"
+- ""
+- FUNC_LIB_TIMEDLOCK )
+-
+-endif( NOT APPLE )
++#if( NOT APPLE )
++#
++# check_library_exists(
++# ${CMAKE_THREAD_LIBS_INIT}
++# "pthread_mutex_timedlock"
++# ""
++# FUNC_LIB_TIMEDLOCK )
++#
++#endif( NOT APPLE )
+
+ if( FUNC_LIB_TIMEDLOCK )
+