summarylogtreecommitdiffstats
path: root/conf-d.patch
diff options
context:
space:
mode:
authorsravanpannala2022-10-14 21:20:31 -0400
committersravanpannala2022-10-14 21:20:31 -0400
commit776f27d86f3fc4033a6a1400499a58b3b5651510 (patch)
tree0f52a0e82b3725fc2e59c068b3af3250cf95dbf2 /conf-d.patch
parent4e80d7130dcaa5ef79d8f5e2bf3120eb27ce9874 (diff)
downloadaur-snapper-git.tar.gz
update PKGBUILD with arch patches
Diffstat (limited to 'conf-d.patch')
-rw-r--r--conf-d.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/conf-d.patch b/conf-d.patch
new file mode 100644
index 000000000000..6dd92c0d7364
--- /dev/null
+++ b/conf-d.patch
@@ -0,0 +1,49 @@
+diff --git a/scripts/pam_snapper_userdel.sh b/scripts/pam_snapper_userdel.sh
+index 30be9be..1ffa63e 100755
+--- a/scripts/pam_snapper_userdel.sh
++++ b/scripts/pam_snapper_userdel.sh
+@@ -40,7 +40,7 @@ fi
+ if [ ${DRYRUN} == 0 ] ; then
+ # Delete the snapper configuration
+ # This deletes $SNAPPERCFGDIR/home_${MYUSER}
+- # removes "home_${MYUSER}" from /etc/sysconfig/snapper
++ # removes "home_${MYUSER}" from /etc/conf.d/snapper
+ # and deletes all snapshots
+ ${CMD_SNAPPER} -c home_${MYUSER} delete-config
+ # Delete the USER's home subvolume
+diff --git a/scripts/snapper-daily b/scripts/snapper-daily
+index 27e7a10..2ee7fff 100755
+--- a/scripts/snapper-daily
++++ b/scripts/snapper-daily
+@@ -9,10 +9,10 @@ export PATH
+
+
+ #
+-# get information from /etc/sysconfig/snapper
++# get information from /etc/conf.d/snapper
+ #
+-if [ -f /etc/sysconfig/snapper ] ; then
+- . /etc/sysconfig/snapper
++if [ -f /etc/conf.d/snapper ] ; then
++ . /etc/conf.d/snapper
+ fi
+
+
+diff --git a/scripts/snapper-hourly b/scripts/snapper-hourly
+index bc6cd4d..1ef49ff 100755
+--- a/scripts/snapper-hourly
++++ b/scripts/snapper-hourly
+@@ -9,10 +9,10 @@ export PATH
+
+
+ #
+-# get information from /etc/sysconfig/snapper
++# get information from /etc/conf.d/snapper
+ #
+-if [ -f /etc/sysconfig/snapper ] ; then
+- . /etc/sysconfig/snapper
++if [ -f /etc/conf.d/snapper ] ; then
++ . /etc/conf.d/snapper
+ fi
+
+