summarylogtreecommitdiffstats
path: root/fix-lib32-makefile.patch
diff options
context:
space:
mode:
authorSudokamikaze2016-12-21 19:10:36 +0200
committerSudokamikaze2016-12-21 19:10:36 +0200
commit76c8a030e224af766e0f2eb323983c17c055464a (patch)
tree348c1c2e56e7355e60b4a3d28899700c757367e4 /fix-lib32-makefile.patch
downloadaur-lib32-caps.tar.gz
initial
Diffstat (limited to 'fix-lib32-makefile.patch')
-rw-r--r--fix-lib32-makefile.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/fix-lib32-makefile.patch b/fix-lib32-makefile.patch
new file mode 100644
index 000000000000..cc1c7b57ba3e
--- /dev/null
+++ b/fix-lib32-makefile.patch
@@ -0,0 +1,38 @@
+diff --git a/Makefile b/Makefile
+index 0f87e02..a6da26b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,12 +1,12 @@
+-PREFIX = /usr/local
++PREFIX = /usr
+
+-CC = g++
++CC = g++ -m32
+
+ # only use -ffast-math if you're feeling mighty adventurous. (g++ issues)
+ OPTS = -O2 -funroll-loops -Wall -fPIC -DPIC
+ #OPTS = -g -DDEBUG
+
+-_LDFLAGS = -nostartfiles -shared
++_LDFLAGS = -nostartfiles -shared -L/usr/lib32
+ STRIP = strip
+
+ -include defines.make
+@@ -23,7 +23,7 @@ HEADERS = $(wildcard *.h) $(wildcard dsp/*.h) $(wildcard util/*.h) $(wildcard ds
+
+ PDF = releases/caps-$(VERSION).pdf
+
+-DEST = $(PREFIX)/lib/ladspa
++DEST = $(PREFIX)/lib32/ladspa
+ RDFDEST = $(PREFIX)/share/ladspa/rdf
+
+ # all systems go -------------------------------------------------------------
+@@ -66,8 +66,6 @@ install: all
+ @$(STRIP) $(PLUG).so > /dev/null
+ install -d $(DEST)
+ install -m 644 $(PLUG).so $(DEST)
+- install -d $(RDFDEST)
+- install -m 644 $(PLUG).rdf $(RDFDEST)
+
+ fake-install: all
+ -rm $(DEST)/$(PLUG).so