summarylogtreecommitdiffstats
path: root/make.patch
diff options
context:
space:
mode:
authorkoneu2016-08-27 11:58:10 +0200
committerkoneu2016-08-27 14:07:39 +0200
commitcb1ff5126c47e2b5d0a231af4ab5c402d53232ca (patch)
tree47927ae70292decff80ec2985bb7fdfcbd2522a8 /make.patch
downloadaur-xrootconsole.tar.gz
initial commit
Diffstat (limited to 'make.patch')
-rw-r--r--make.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/make.patch b/make.patch
new file mode 100644
index 000000000000..d9ab1b1c9dca
--- /dev/null
+++ b/make.patch
@@ -0,0 +1,41 @@
+--- a/Makefile
++++ b/Makefile
+@@ -32,10 +32,11 @@
+ #
+ ###########################################################################
+
++PREFIX ?= /usr/local
+ EXEC = xrootconsole
+-BINDIR = /usr/local/bin
++BINDIR = $(PREFIX)/bin
+ MANFILE = xrootconsole.1
+-MANDIR = /usr/local/share/man/man1
++MANDIR = $(PREFIX)/share/man/man1
+
+ VERSION = $(shell tag=$$(echo '$$Name: RELEASE-0_6 $$' | sed -e 's/\$$//g' -e 's/Name://g'); \
+ if [ $$tag ]; \
+@@ -43,13 +44,12 @@ VERSION = $(shell tag=$$(echo '$$Name: RELEASE-0_6 $$' | sed -e 's/\$$//g' -e 's
+ else echo Bleeding Edge Version; \
+ fi;)
+
+-CC = gcc
+-CPPFLAGS =
++CC ?= gcc
+
+ # for production
+-CFLAGS = -O2 -DNDEBUG -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION)\"" \
++CFLAGS += -O2 -DNDEBUG -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION)\"" \
+ -I /usr/X11R6/include
+-LDFLAGS = -s
++LDFLAGS += -s
+
+ # for testing
+ #CFLAGS = -g -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION) (debug build)\"" \
+@@ -76,5 +76,7 @@ realclean:
+ rm -f $(EXEC) *.o core *~
+
+ install: $(EXEC)
++ mkdir -p $(BINDIR)
+ cp $(EXEC) $(BINDIR)
++ mkdir -p $(MANDIR)
+ cp $(MANFILE) $(MANDIR)