summarylogtreecommitdiffstats
path: root/osirisedit-makefile-flags.patch
diff options
context:
space:
mode:
authorDaniel Appelt2022-03-04 20:33:08 +0100
committerDaniel Appelt2022-03-04 20:33:08 +0100
commitf12c38c7e0e566641d1d9b3f20a2332854aadd17 (patch)
tree4dcc78757e8eac6160564bbd9bd88c123d2d2baa /osirisedit-makefile-flags.patch
downloadaur-osirisedit.tar.gz
Initial commit
Diffstat (limited to 'osirisedit-makefile-flags.patch')
-rw-r--r--osirisedit-makefile-flags.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/osirisedit-makefile-flags.patch b/osirisedit-makefile-flags.patch
new file mode 100644
index 000000000000..a96a6f01dead
--- /dev/null
+++ b/osirisedit-makefile-flags.patch
@@ -0,0 +1,22 @@
+diff --git a/Makefile b/Makefile
+index 2b0de9f..14ee615 100644
+--- a/Makefile
++++ b/Makefile
+@@ -22,11 +22,14 @@ SOURCES = \
+ include Makefile-arch.inc
+ ifeq ($(ARCH),lin)
+ # Linux
+- FLAGS += -DARCH_LIN $(shell pkg-config --cflags gtk+-2.0)
++ FLAGS += -DARCH_LIN \
++ $(shell pkg-config --cflags gtk+-2.0) \
++ $(shell pkg-config --cflags sdl2)
+ LDFLAGS += -static-libstdc++ -static-libgcc \
+ -lGL -lpthread \
+- -Ldep/lib -lSDL2 -lsamplerate -lsndfile -ljansson -lcurl \
+- -lgtk-x11-2.0 -lgobject-2.0
++ -Ldep/lib -lsamplerate -lsndfile -ljansson -lcurl \
++ $(shell pkg-config --libs sdl2) \
++ $(shell pkg-config --libs gtk+-2.0)
+ SOURCES += ext/osdialog/osdialog_gtk2.c
+ else ifeq ($(ARCH),mac)
+ # Mac