summarylogtreecommitdiffstats
path: root/pyproject.toml.patch
diff options
context:
space:
mode:
authorfabrixxm2024-04-24 16:23:29 +0200
committerfabrixxm2024-04-24 16:23:29 +0200
commitb4641470d2678bc2e46df7fca9deebeca6e9e378 (patch)
tree4baf2313ea94a309fe502619768ad0ed73a8409f /pyproject.toml.patch
parent428efaab10bab20f9fe749e9db95fd684bda2597 (diff)
downloadaur-lesana.tar.gz
patch pyproject to not require setuptools-scm to get version
Diffstat (limited to 'pyproject.toml.patch')
-rw-r--r--pyproject.toml.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/pyproject.toml.patch b/pyproject.toml.patch
new file mode 100644
index 000000000000..9b7883547f1b
--- /dev/null
+++ b/pyproject.toml.patch
@@ -0,0 +1,31 @@
+--- a/pyproject.toml 2024-04-24 16:19:21.420395714 +0200
++++ b/pyproject.toml 2024-04-24 16:20:33.304790713 +0200
+@@ -1,9 +1,10 @@
+ [build-system]
+-requires = ["setuptools", "setuptools-scm"]
++requires = ["setuptools"]
+ build-backend = "setuptools.build_meta"
+
+ [project]
+ name = "lesana"
++version = "0.10.1"
+ authors = [
+ {name = "Elena ``of Valhalla'' Grandi", email = "valhalla@trueelena.org"},
+ ]
+@@ -34,7 +35,6 @@
+ "python-dateutil",
+ #"xapian >= 1.4",
+ ]
+-dynamic = ["version"]
+
+ [project.optional-dependencies]
+ cli = [
+@@ -54,8 +54,6 @@
+ Changelog = "https://git.sr.ht/~valhalla/lesana/tree/master/item/CHANGELOG.rst"
+ "Mailing lists" = "https://sr.ht/~valhalla/lesana/lists"
+
+-[tool.setuptools_scm]
+-version_file = "lesana/_version.py"
+
+ [[tool.mypy.overrides]]
+ module = [