summarylogtreecommitdiffstats
path: root/target-optimizing.patch
diff options
context:
space:
mode:
authoryjun2021-02-13 16:25:34 +0800
committeryjun2021-02-13 16:25:34 +0800
commit330162eb2a5a027ee8b983b25684d12714be5abf (patch)
tree3e431908a51a280724cd7d8493a8f64f9dcdc764 /target-optimizing.patch
parent94af533d6c3208abcae8bf2b02b35ab5d84493ce (diff)
downloadaur-onscripter-gbk-git.tar.gz
fixed patch error
Diffstat (limited to 'target-optimizing.patch')
-rw-r--r--target-optimizing.patch3
1 files changed, 1 insertions, 2 deletions
diff --git a/target-optimizing.patch b/target-optimizing.patch
index 6649c5b06a0a..f304ce07bf19 100644
--- a/target-optimizing.patch
+++ b/target-optimizing.patch
@@ -1,11 +1,10 @@
--- onscripter-jh/Makefile.Linux 2021-02-12 13:19:35.333287357 +0800
+++ onscripter-jh.new/Makefile.Linux 2021-02-12 13:18:28.066124344 +0800
-@@ -55,6 +55,19 @@
+@@ -55,6 +55,18 @@
LIBS += -llua5.1
EXT_OBJS += LUAHandler$(OBJSUFFIX)
+# optional: SIMD optimizing
-+DEFS += -DUSE_SIMD -DUSE_SIMD_X86_SSE2
+ARCH = $(shell uname -m)
+DEFS += -DUSE_SIMD
+ifneq ($(filter i686 x86_64,$(ARCH)),)