summarylogtreecommitdiffstats
path: root/target-optimizing.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target-optimizing.patch')
-rw-r--r--target-optimizing.patch3
1 files changed, 1 insertions, 2 deletions
diff --git a/target-optimizing.patch b/target-optimizing.patch
index 6649c5b06a0a..f304ce07bf19 100644
--- a/target-optimizing.patch
+++ b/target-optimizing.patch
@@ -1,11 +1,10 @@
--- onscripter-jh/Makefile.Linux 2021-02-12 13:19:35.333287357 +0800
+++ onscripter-jh.new/Makefile.Linux 2021-02-12 13:18:28.066124344 +0800
-@@ -55,6 +55,19 @@
+@@ -55,6 +55,18 @@
LIBS += -llua5.1
EXT_OBJS += LUAHandler$(OBJSUFFIX)
+# optional: SIMD optimizing
-+DEFS += -DUSE_SIMD -DUSE_SIMD_X86_SSE2
+ARCH = $(shell uname -m)
+DEFS += -DUSE_SIMD
+ifneq ($(filter i686 x86_64,$(ARCH)),)