summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6185631ac372..7e97dcbda9df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Mar 16 23:56:01 UTC 2018
+# Sat Mar 17 14:18:14 UTC 2018
pkgbase = aseprite
pkgdesc = Create animated sprites and pixel art
pkgver = 1.2.7
- pkgrel = 1
+ pkgrel = 2
url = http://www.aseprite.org/
arch = x86_64
arch = i686
@@ -20,7 +20,6 @@ pkgbase = aseprite
depends = freetype2
depends = libwebp
depends = harfbuzz
- depends = allegro4
conflicts = aseprite-git
conflicts = aseprite-gpl
source = https://github.com/aseprite/aseprite/releases/download/v1.2.7/Aseprite-v1.2.7-Source.zip
diff --git a/PKGBUILD b/PKGBUILD
index da72093d212e..738dd71c7b82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
pkgname=aseprite
pkgver=1.2.7
-pkgrel=1
+pkgrel=2
pkgdesc='Create animated sprites and pixel art'
arch=('x86_64' 'i686')
url="http://www.aseprite.org/"
license=('custom')
-depends=('cmark' 'pixman' 'curl' 'giflib' 'zlib' 'libpng' 'libjpeg-turbo' 'tinyxml' 'freetype2' 'libwebp' 'harfbuzz' 'allegro4')
+depends=('cmark' 'pixman' 'curl' 'giflib' 'zlib' 'libpng' 'libjpeg-turbo' 'tinyxml' 'freetype2' 'libwebp' 'harfbuzz')
makedepends=('cmake')
conflicts=("aseprite-git" "aseprite-gpl")
source=("https://github.com/${pkgname}/${pkgname}/releases/download/v${pkgver}/Aseprite-v${pkgver}-Source.zip"
@@ -28,6 +28,10 @@ build() {
fi
mkdir -p build && cd build
+
+ # CMake config notes:
+ # Do not build using the shared allegro4. Weird graphical glitches happen when linking to the library from the official repo
+
cmake -DUSE_SHARED_PIXMAN=ON \
-DWITH_WEBP_SUPPORT=ON \
-DUSE_SHARED_LIBWEBP=ON \
@@ -42,7 +46,7 @@ build() {
-DUSE_SHARED_CMARK=ON \
-DENABLE_UPDATER=OFF \
-DUSE_SHARED_FREETYPE=ON \
- -DUSE_SHARED_ALLEGRO4=ON \
+ -DUSE_SHARED_ALLEGRO4=OFF \
-DCMAKE_INSTALL_PREFIX:STRING=/usr ..
make $MAKEFLAGS