summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--P950ER.patch19
-rw-r--r--PKGBUILD18
-rw-r--r--linux_4_14.diff13
4 files changed, 33 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b1b34c015b9..4046ab005a1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clevo-xsm-wmi-dkms
pkgdesc = A reverse engineering driver for the Clevo SM series backlight keyboard (DKMS version)
pkgver = 1.1
- pkgrel = 6
+ pkgrel = 7
url = https://bitbucket.org/tuxedocomputers/clevo-xsm-wmi
install = clevo-xsm-wmi-dkms.install
arch = i686
@@ -16,14 +16,14 @@ pkgbase = clevo-xsm-wmi-dkms
conflicts = tuxedo-wmi
conflicts = tuxedo-wmi-dkms
options = !emptydirs
- source = clevo-xsm-wmi-1.1.src.tar.gz::https://bitbucket.org/tuxedocomputers/clevo-xsm-wmi/get/v1.1.tar.gz
+ source = clevo-xsm-wmi-dcf282992eb8.src.tar.gz::https://bitbucket.org/tuxedocomputers/clevo-xsm-wmi/get/dcf282992eb8.tar.gz
+ source = P950ER.patch
source = dkms.conf
source = Makefile
- source = linux_4_14.diff
- sha256sums = 630ff6dbfa90c8a9285badf75b60579b2a9495e85862b62ef77a3654535e4b72
+ sha256sums = 68d3aa0c73b8cfef237f517d129c730e248de5c3720090f04f0e36f58ea5843a
+ sha256sums = ccd1a9277c055b702eb05662484c0c6b0e62f6fae255030d3a30975984b0c427
sha256sums = 0cdf0213692a71d69f54730d1856d9f1e7b3d363d9b2a66a5d6bb363e8d8212f
sha256sums = fb20847bde676a305fda41b865b46aff52ae9de60e1262d6e9725a71d72b806b
- sha256sums = 8aac7728933f6dd8796853b389049829fb46a3042ff423ee087ca0f86a3196a0
pkgname = clevo-xsm-wmi-dkms
diff --git a/P950ER.patch b/P950ER.patch
new file mode 100644
index 000000000000..8416b0b8e0b8
--- /dev/null
+++ b/P950ER.patch
@@ -0,0 +1,19 @@
+diff --git a/module/clevo-xsm-wmi.c b/module/clevo-xsm-wmi.c
+index e045d7e..0c7e3e8 100644
+--- a/module/clevo-xsm-wmi.c
++++ b/module/clevo-xsm-wmi.c
+@@ -1638,6 +1638,14 @@ static struct dmi_system_id clevo_xsm_dmi_table[] __initdata = {
+ .callback = clevo_xsm_dmi_matched,
+ .driver_data = &kb_full_color_ops,
+ },
++ {
++ .ident = "Clevo P950ER",
++ .matches = {
++ DMI_MATCH(DMI_PRODUCT_NAME, "P95xER"),
++ },
++ .callback = clevo_xsm_dmi_matched,
++ .driver_data = &kb_full_color_ops,
++ },
+ {
+ /* terminating NULL entry */
+ },
diff --git a/PKGBUILD b/PKGBUILD
index 9493d9ad83a5..2033bdf7f831 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@ _pkgbase='clevo-xsm-wmi'
_modname=$_pkgbase
pkgname="${_pkgbase}-dkms"
pkgver='1.1'
-_pkgtag='6bfe9fe44e04'
-pkgrel=6
+_pkgtag='dcf282992eb8'
+pkgrel=7
pkgdesc='A reverse engineering driver for the Clevo SM series backlight keyboard (DKMS version)'
arch=('i686' 'x86_64')
license=('GPL')
@@ -14,19 +14,19 @@ options=(!emptydirs)
conflicts=("$_pkgbase" 'tuxedo-wmi' 'tuxedo-wmi-dkms')
provides=("$_pkgbase")
depends=('dkms' 'gcc' 'make' 'linux-headers')
-source=("clevo-xsm-wmi-${pkgver}.src.tar.gz::https://bitbucket.org/tuxedocomputers/clevo-xsm-wmi/get/v${pkgver}.tar.gz"
+source=("clevo-xsm-wmi-${_pkgtag}.src.tar.gz::https://bitbucket.org/tuxedocomputers/clevo-xsm-wmi/get/${_pkgtag}.tar.gz"
+ "P950ER.patch"
"dkms.conf"
- "Makefile"
- "linux_4_14.diff")
-sha256sums=('630ff6dbfa90c8a9285badf75b60579b2a9495e85862b62ef77a3654535e4b72'
+ "Makefile")
+sha256sums=('dd326e9855b708b7ab922d47b3abcd24c53a3af4fdc1c164399c8dbdb5a7f6ce'
+ 'ccd1a9277c055b702eb05662484c0c6b0e62f6fae255030d3a30975984b0c427'
'0cdf0213692a71d69f54730d1856d9f1e7b3d363d9b2a66a5d6bb363e8d8212f'
- 'fb20847bde676a305fda41b865b46aff52ae9de60e1262d6e9725a71d72b806b'
- '8aac7728933f6dd8796853b389049829fb46a3042ff423ee087ca0f86a3196a0')
+ 'fb20847bde676a305fda41b865b46aff52ae9de60e1262d6e9725a71d72b806b')
install='clevo-xsm-wmi-dkms.install'
prepare() {
cd "${srcdir}/tuxedocomputers-clevo-xsm-wmi-${_pkgtag}"
- patch -i "${srcdir}/linux_4_14.diff" -p1
+ patch -i "${srcdir}/P950ER.patch" -p1
}
package() {
diff --git a/linux_4_14.diff b/linux_4_14.diff
deleted file mode 100644
index 39263517d07e..000000000000
--- a/linux_4_14.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/module/clevo-xsm-wmi.c b/module/clevo-xsm-wmi.c
-index 162577b..2e7406a 100644
---- a/module/clevo-xsm-wmi.c
-+++ b/module/clevo-xsm-wmi.c
-@@ -431,7 +431,7 @@ static int clevo_xsm_wmi_evaluate_wmbb_method(u32 method_id, u32 arg,
-
- CLEVO_XSM_DEBUG("%0#4x IN : %0#6x\n", method_id, arg);
-
-- status = wmi_evaluate_method(CLEVO_GET_GUID, 0x01,
-+ status = wmi_evaluate_method(CLEVO_GET_GUID, 0x00,
- method_id, &in, &out);
-
- if (unlikely(ACPI_FAILURE(status)))