summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
-rw-r--r--code-liveshare.diff12
-rw-r--r--code-liveshare.patch15
-rw-r--r--product_json.diff20
-rw-r--r--product_json.patch21
6 files changed, 57 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d326504095f..099b969e7a65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-git
pkgdesc = The Open Source build of Visual Studio Code (vscode) editor - git latest
- pkgver = 1.16.0.r25587.g7d39e805fb
+ pkgver = 1.16.0.r25714.g2328356959
pkgrel = 1
url = https://github.com/Microsoft/vscode
arch = i686
@@ -12,7 +12,7 @@ pkgbase = code-git
makedepends = python2
makedepends = git
makedepends = yarn
- makedepends = nodejs-lts-carbon
+ makedepends = nodejs-lts-dubnium
depends = electron
depends = libsecret
depends = libxkbfile
@@ -22,13 +22,13 @@ pkgbase = code-git
source = git+https://github.com/Microsoft/vscode
source = code-git.js
source = code-git.sh
- source = code-liveshare.patch
- source = product_json.patch
- sha256sums = SKIP
- sha256sums = 64aca444a714dd67da6d5b71ab8d0255e767cb265918d556b3bf8194fca0a7ef
- sha256sums = df452e6f64f62081aa4a8da69a071b2c122095eea48dca409a7a851243b9ff36
- sha256sums = b42df6bbf1160f9602f10245b5442295d6e3a86731a799281dd4b77083aa00bc
- sha256sums = d3eb8c0e5ddc2b0a6089cec2f34346bf8080048ce3b3eb6918467eedd741cae0
+ source = product_json.diff
+ source = code-liveshare.diff
+ sha512sums = SKIP
+ sha512sums = 889ca4d4b810b4a67319cece0e1bfeae61b33905adef64f9b27152e43e112dc53a94b1875fe0a810f0d0192dec0107aed2d01c12d6a17427db4261858f96a02a
+ sha512sums = 5d1cf747d365da2e12250079ba986ad5a7e70a7966900ee77a557b5989978cb24a6a8682342e87f19ffe3666d7a91bfd9004b1fc0c1da08d2ba9241e7a808ff5
+ sha512sums = 8ec47e497287d67f37e7b669af416f43d5cdbd4574892867d7b95996ef5de53640b5bc919b06b177e1fd91cb005579d6ed0c17325117b9914ba7cf28f5f06e40
+ sha512sums = 0bd10ca06dea22854e47fc45d833756ee8d7bf714c88f63feef44e0b0b5da052fba3c27d001865e3389f391cd7b888d92dc0ba44029fa5c736225da3cf2f9a46
pkgname = code-git
diff --git a/PKGBUILD b/PKGBUILD
index 3c6072df07a2..3839a3b4d4ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,26 @@
pkgname=code-git
pkgdesc='The Open Source build of Visual Studio Code (vscode) editor - git latest'
-pkgver=1.16.0.r25587.g7d39e805fb
+pkgver=1.16.0.r25714.g2328356959
pkgrel=1
arch=('i686' 'x86_64' 'armv7h')
url='https://github.com/Microsoft/vscode'
license=('MIT')
depends=('electron' 'libsecret' 'libxkbfile' 'ripgrep')
-makedepends=('npm' 'gulp' 'python2' 'git' 'yarn' 'nodejs-lts-carbon')
+makedepends=('npm' 'gulp' 'python2' 'git' 'yarn' 'nodejs-lts-dubnium')
conflicts=('visual-studio-code-git')
provides=('visual-studio-code-git')
source=("git+https://github.com/Microsoft/vscode"
"${pkgname}.js"
"${pkgname}.sh"
- "code-liveshare.patch"
- "product_json.patch")
-sha256sums=('SKIP'
- '64aca444a714dd67da6d5b71ab8d0255e767cb265918d556b3bf8194fca0a7ef'
- 'df452e6f64f62081aa4a8da69a071b2c122095eea48dca409a7a851243b9ff36'
- 'b42df6bbf1160f9602f10245b5442295d6e3a86731a799281dd4b77083aa00bc'
- 'd3eb8c0e5ddc2b0a6089cec2f34346bf8080048ce3b3eb6918467eedd741cae0')
+ "product_json.diff"
+ "code-liveshare.diff")
+sha512sums=('SKIP'
+ '889ca4d4b810b4a67319cece0e1bfeae61b33905adef64f9b27152e43e112dc53a94b1875fe0a810f0d0192dec0107aed2d01c12d6a17427db4261858f96a02a'
+ '5d1cf747d365da2e12250079ba986ad5a7e70a7966900ee77a557b5989978cb24a6a8682342e87f19ffe3666d7a91bfd9004b1fc0c1da08d2ba9241e7a808ff5'
+ '8ec47e497287d67f37e7b669af416f43d5cdbd4574892867d7b95996ef5de53640b5bc919b06b177e1fd91cb005579d6ed0c17325117b9914ba7cf28f5f06e40'
+ '0bd10ca06dea22854e47fc45d833756ee8d7bf714c88f63feef44e0b0b5da052fba3c27d001865e3389f391cd7b888d92dc0ba44029fa5c736225da3cf2f9a46')
case "$CARCH" in
i686)
@@ -51,14 +51,14 @@ prepare() {
# This patch no longer contains proprietary modifications.
# See https://github.com/Microsoft/vscode/issues/31168 for details.
- patch -p1 -i "${srcdir}/product_json.patch"
+ patch -p0 -i "${srcdir}/product_json.diff"
local _commit=$(cd "${srcdir}/vscode" && git rev-parse HEAD)
local _datestamp=$(date -u -Is | sed 's/\+00:00/Z/')
sed -e "s/@COMMIT@/${_commit}/" -e "s/@DATE@/${_datestamp}/" \
-i product.json
# See https://github.com/MicrosoftDocs/live-share/issues/262 for details
- patch -p1 -i "${srcdir}/code-liveshare.patch"
+ patch -p1 -i "${srcdir}/code-liveshare.diff"
# Build native modules for system electron
local _target=$(</usr/lib/electron/version)
@@ -72,6 +72,11 @@ prepare() {
s|@@ICON@@|code-git|g
s|@@LICENSE@@|MIT|g
s|inode/directory;||' resources/linux/code.{appdata.xml,desktop}
+
+ # Fix bin path
+ sed -i "s|return path.join(path.dirname(execPath), 'bin', \`\${product.applicationName}\`);|return '/usr/bin/${pkgname}';|g
+ s|return path.join(appRoot, 'scripts', 'code-cli.sh');|return '/usr/bin/${pkgname}';|g" \
+ src/vs/platform/environment/node/environmentService.ts
}
build() {
diff --git a/code-liveshare.diff b/code-liveshare.diff
new file mode 100644
index 000000000000..ba8912565a89
--- /dev/null
+++ b/code-liveshare.diff
@@ -0,0 +1,12 @@
+diff --git a/product.json b/product.json
+index b250c66fc4..8a9befcfbb 100644
+--- a/product.json
++++ b/product.json
+@@ -19,6 +19,7 @@
+ "reportIssueUrl": "https://github.com/Microsoft/vscode/issues/new",
+ "urlProtocol": "code-oss",
+ "extensionAllowedProposedApi": [
++ "ms-vsliveshare.vsliveshare",
+ "ms-vscode.references-view"
+ ],
+ "quality": "stable",
diff --git a/code-liveshare.patch b/code-liveshare.patch
deleted file mode 100644
index 40a2e8f7850a..000000000000
--- a/code-liveshare.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -rupN a/product.json b/product.json
---- a/product.json 2018-11-12 15:11:50.820948673 -0800
-+++ b/product.json 2018-11-12 15:12:53.441641156 -0800
-@@ -21,7 +21,10 @@
- "reportIssueUrl": "https://github.com/Microsoft/vscode/issues/new",
- "urlProtocol": "code-oss",
- "extensionAllowedProposedApi": [
-- "ms-vscode.references-view"
-+ "ms-vscode.references-view",
-+ "ms-vsliveshare.vsliveshare",
-+ "ms-vscode.node-debug",
-+ "ms-vscode.node-debug2"
- ],
- "quality": "stable",
- "extensionsGallery": {
diff --git a/product_json.diff b/product_json.diff
new file mode 100644
index 000000000000..173b26efb61d
--- /dev/null
+++ b/product_json.diff
@@ -0,0 +1,20 @@
+--- product.json 2019-04-06 13:26:49.879655883 +0100
++++ product.json 2019-04-06 13:26:37.399656243 +0100
+@@ -1,4 +1,17 @@
+ {
++ "quality": "stable",
++ "extensionsGallery": {
++ "serviceUrl": "https://marketplace.visualstudio.com/_apis/public/gallery",
++ "cacheUrl": "https://vscode.blob.core.windows.net/gallery/index",
++ "itemUrl": "https://marketplace.visualstudio.com/items"
++ },
++ "documentationUrl": "https://code.visualstudio.com/docs",
++ "requestFeatureUrl": "https://github.com/Microsoft/vscode/issues",
++ "introductoryVideosUrl": "https://go.microsoft.com/fwlink/?linkid=832146",
++ "tipsAndTricksUrl": "https://go.microsoft.com/fwlink/?linkid=852118",
++ "keyboardShortcutsUrlLinux": "https://go.microsoft.com/fwlink/?linkid=832144",
++ "commit": "@COMMIT@",
++ "date": "@DATE@",
+ "nameShort": "Code - OSS",
+ "nameLong": "Code - OSS",
+ "applicationName": "code-oss",
diff --git a/product_json.patch b/product_json.patch
deleted file mode 100644
index 444f33d2f678..000000000000
--- a/product_json.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -rupN a/product.json b/product.json
---- a/product.json 2018-11-12 15:09:13.479207928 -0800
-+++ b/product.json 2018-11-12 15:10:06.309792546 -0800
-@@ -22,5 +22,15 @@
- "urlProtocol": "code-oss",
- "extensionAllowedProposedApi": [
- "ms-vscode.references-view"
-- ]
-+ ],
-+ "quality": "stable",
-+ "extensionsGallery": {
-+ "serviceUrl": "https://marketplace.visualstudio.com/_apis/public/gallery",
-+ "cacheUrl": "https://vscode.blob.core.windows.net/gallery/index",
-+ "itemUrl": "https://marketplace.visualstudio.com/items"
-+ },
-+ "documentationUrl": "https://github.com/microsoft/vscode-docs",
-+ "requestFeatureUrl": "https://github.com/Microsoft/vscode/issues",
-+ "commit": "@COMMIT@",
-+ "date": "@DATE@"
- }
-\ No newline at end of file