summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
-rw-r--r--conduit.toml58
3 files changed, 48 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e061d885cf09..306b3d852ce1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = conduit-bin
- pkgdesc = stable, pre-compiled versions of the Conduit server (Matrix protocol)
- pkgver = 0.6.0
+ pkgdesc = stable, binary, static versions of the Conduit server (Matrix protocol)
+ pkgver = 0.7.0
pkgrel = 1
url = https://conduit.rs
arch = x86_64
arch = aarch64
- arch = armv7h
license = Apache-2.0
provides = conduit
conflicts = conduit
@@ -14,15 +13,13 @@ pkgbase = conduit-bin
source = conduit.service
source = tmpfiles.conf
source = sysusers.conf
- sha256sums = 31214654367ca03c0e2b6cd615b6f8febfae249a6771f956b2a0996a11b6b98f
+ sha256sums = 27f0b70dd359ce09372484fd2f511877e198c134a620e801025095510b8a46a9
sha256sums = 1c5f53cc49bae88b80281ab6edcf08e18430e5db668eaa186b8be4928f850594
sha256sums = 4316952810a2295b81d7faf3e28c371dd63629671c4b7e3c39bfbae5ab9e2db6
sha256sums = 0f454a2a5af857fe978e2276798fb357b4578c6ee705664a794426c8b7576a4c
- source_x86_64 = conduit::https://gitlab.com/famedly/conduit/-/jobs/artifacts/master/raw/build-output/linux_amd64/conduit?job=docker:master
+ source_x86_64 = conduit::https://gitlab.com/api/v4/projects/famedly%2Fconduit/jobs/artifacts/master/raw/x86_64-unknown-linux-musl?job=artifacts
sha256sums_x86_64 = eb085e2a43e9225da1fafe01956b361a48b48a1dce9370c3e09bbc120ff6998d
- source_aarch64 = conduit::https://gitlab.com/famedly/conduit/-/jobs/artifacts/master/raw/build-output/linux_arm64/conduit?job=docker:master
- sha256sums_aarch64 = ef089841b2ff23285fa458459a3add2a608c0ec0702434b1a8973d2cac1b978f
- source_armv7h = conduit::https://gitlab.com/famedly/conduit/-/jobs/artifacts/master/raw/build-output/linux_arm_v7/conduit?job=docker:master
- sha256sums_armv7h = 595534a8eb19496f7ac39130e62a29645fc04b001faad72032144ab97467d394
+ source_aarch64 = conduit::https://gitlab.com/api/v4/projects/famedly%2Fconduit/jobs/artifacts/master/raw/aarch64-unknown-linux-musl?job=artifacts
+ sha256sums_aarch64 = 371a6572c370f82810e41666fe71bdacfd7b611b245310d6465392e9da7c3130
pkgname = conduit-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8076266cf819..356f746954a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: lafleur <lafleur at boum dot org>
pkgname=conduit-bin
_pkgname=${pkgname/-bin/}
-pkgver=0.6.0
+pkgver=0.7.0
pkgrel=1
-pkgdesc="stable, pre-compiled versions of the Conduit server (Matrix protocol)"
-arch=('x86_64' 'aarch64' 'armv7h')
+pkgdesc="stable, binary, static versions of the Conduit server (Matrix protocol)"
+arch=('x86_64' 'aarch64')
url="https://conduit.rs"
license=('Apache-2.0')
provides=("${_pkgname}")
@@ -17,9 +17,8 @@ source=(
'tmpfiles.conf'
'sysusers.conf'
)
-source_x86_64=("${_pkgname}::https://gitlab.com/famedly/conduit/-/jobs/artifacts/master/raw/build-output/linux_amd64/${_pkgname}?job=docker:master")
-source_aarch64=("${_pkgname}::https://gitlab.com/famedly/conduit/-/jobs/artifacts/master/raw/build-output/linux_arm64/${_pkgname}?job=docker:master")
-source_armv7h=("${_pkgname}::https://gitlab.com/famedly/conduit/-/jobs/artifacts/master/raw/build-output/linux_arm_v7/${_pkgname}?job=docker:master")
+source_x86_64=("${_pkgname}::https://gitlab.com/api/v4/projects/famedly%2Fconduit/jobs/artifacts/master/raw/x86_64-unknown-linux-musl?job=artifacts")
+source_aarch64=("${_pkgname}::https://gitlab.com/api/v4/projects/famedly%2Fconduit/jobs/artifacts/master/raw/aarch64-unknown-linux-musl?job=artifacts")
package() {
install -vDm644 "${_pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${_pkgname}.service"
@@ -29,10 +28,9 @@ package() {
install -vDm644 tmpfiles.conf "${pkgdir}/usr/lib/tmpfiles.d/${_pkgname}.conf"
}
-sha256sums=('31214654367ca03c0e2b6cd615b6f8febfae249a6771f956b2a0996a11b6b98f'
+sha256sums=('27f0b70dd359ce09372484fd2f511877e198c134a620e801025095510b8a46a9'
'1c5f53cc49bae88b80281ab6edcf08e18430e5db668eaa186b8be4928f850594'
'4316952810a2295b81d7faf3e28c371dd63629671c4b7e3c39bfbae5ab9e2db6'
'0f454a2a5af857fe978e2276798fb357b4578c6ee705664a794426c8b7576a4c')
sha256sums_x86_64=('eb085e2a43e9225da1fafe01956b361a48b48a1dce9370c3e09bbc120ff6998d')
-sha256sums_aarch64=('ef089841b2ff23285fa458459a3add2a608c0ec0702434b1a8973d2cac1b978f')
-sha256sums_armv7h=('595534a8eb19496f7ac39130e62a29645fc04b001faad72032144ab97467d394')
+sha256sums_aarch64=('371a6572c370f82810e41666fe71bdacfd7b611b245310d6465392e9da7c3130')
diff --git a/conduit.toml b/conduit.toml
index ced00b4fbd4c..d03c13fed82e 100644
--- a/conduit.toml
+++ b/conduit.toml
@@ -1,24 +1,29 @@
-[global]
-# Enables registration. If set to false, no users can register on this server.
-allow_registration = false
+# =============================================================================
+# This is the official example config for Conduit.
+# If you use it for your server, you will need to adjust it to your own needs.
+# At the very least, change the server_name field!
+# =============================================================================
+
+[global]
# The server_name is the pretty name of this server. It is used as a suffix for user
# and room ids. Examples: matrix.org, conduit.rs
# The Conduit server needs all /_matrix/ requests to be reachable at
# https://your.server.name/ on port 443 (client-server) and 8448 (federation).
-# If that's not possible for you, you can create /.well-known files to
-# redirect requests. See
+# If that's not possible for you, you can create /.well-known files to redirect
+# requests. See
# https://matrix.org/docs/spec/client_server/latest#get-well-known-matrix-client
# and
# https://matrix.org/docs/spec/server_server/r0.1.4#get-well-known-matrix-server
# for more information
-server_name = "YOUR_URL_HERE"
+# YOU NEED TO EDIT THIS
+#server_name = "your.server.name"
# This is the only directory where Conduit will save its data
-database_path = "/var/lib/conduit/"
+database_path = "/var/lib/matrix-conduit/"
database_backend = "rocksdb"
# The port Conduit will be running on. You need to set up a reverse proxy in
@@ -30,27 +35,34 @@ port = 6167
# Max size for uploads
max_request_size = 20_000_000 # in bytes
-allow_federation = true
+# Enables registration. If set to false, no users can register on this server.
+allow_registration = true
-trusted_servers = ["matrix.org"]
+# A static registration token that new users will have to provide when creating
+# an account. YOU NEED TO EDIT THIS.
+# - Insert a password that users will have to enter on registration
+# - Start the line with '#' to remove the condition
+registration_token = ""
-# How many requests Conduit sends to other servers at the same time.
-#max_concurrent_requests = 100
+allow_federation = true
+allow_check_for_updates = true
-log = "warn,state_res=warn,rocket=off,_=off,sled=off"
+# Enable the display name lightning bolt on registration.
+enable_lightning_bolt = true
-# This makes sure Conduit can only be reached using the reverse proxy
-address = "127.0.0.1"
-# If Conduit is running in a container, make sure the reverse proxy (ie.
-# Traefik) can reach it.
-#address = "0.0.0.0"
+# Servers listed here will be used to gather public keys of other servers.
+# Generally, copying this exactly should be enough. (Currently, Conduit doesn't
+# support batched key requests, so this list should only contain Synapse
+# servers.)
+trusted_servers = ["matrix.org"]
+#max_concurrent_requests = 100 # How many requests Conduit sends to other servers at the same time
-# STUN/TURN usage.
-turn_uris = ["turn:presentmatter.one?transport=udp", "turn:presentmatter.one?transport=tcp"]
+# Controls the log verbosity. See also [here][0].
+#
+# [0]: https://docs.rs/tracing-subscriber/latest/tracing_subscriber/filter/struct.EnvFilter.html#directives
+#log = "..."
-turn_secret = "YOUR_TURN_SECRET_HERE"
-# Alternatively, user and password:
-#turn_username = ""
-#turn_password = ""
+address = "127.0.0.1" # This makes sure Conduit can only be reached using the reverse proxy
+#address = "0.0.0.0" # If Conduit is running in a container, make sure the reverse proxy (ie. Traefik) can reach it.