summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc6969c6556b..d60e08c9e130 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = core-lightning-git
pkgdesc = A lightweight, highly customizable and standard compliant implementation of the Lightning Network protocol.
- pkgver = 23.08rc1.r13429.568f27783
+ pkgver = 23.08.r13576.990096f90
pkgrel = 1
url = https://github.com/ElementsProject/lightning
arch = i686
@@ -11,10 +11,16 @@ pkgbase = core-lightning-git
makedepends = python-pytest
makedepends = python-mako
makedepends = mrkd
+ makedepends = python-poetry
depends = gmp
depends = libsodium
depends = sqlite
depends = python-grpcio-tools
+ depends = python-flask
+ depends = python-json5
+ depends = gunicorn
+ depends = python-flask-restx
+ provides = python-pyln-client
source = git+https://github.com/ElementsProject/lightning.git
source = git+https://github.com/zserge/jsmn.git
source = git+https://github.com/ianlancetaylor/libbacktrace.git
diff --git a/PKGBUILD b/PKGBUILD
index 394ecfcb0c05..39981704ef36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Contributor: Nicola Squartini <tensor5@gmail.com>
pkgname=core-lightning-git
-pkgver=23.08rc1.r13429.568f27783
+pkgver=23.08.r13576.990096f90
pkgrel=1
pkgdesc='A lightweight, highly customizable and standard compliant implementation of the Lightning Network protocol.'
arch=('i686' 'x86_64')
url='https://github.com/ElementsProject/lightning'
license=('custom')
-depends=('gmp' 'libsodium' 'sqlite' 'python-grpcio-tools')
-makedepends=('clang' 'git' 'python-pytest' 'python-mako' 'mrkd')
+depends=('gmp' 'libsodium' 'sqlite' 'python-grpcio-tools' 'python-flask' 'python-json5' 'gunicorn' 'python-flask-restx')
+makedepends=('clang' 'git' 'python-pytest' 'python-mako' 'mrkd' 'python-poetry')
+provides=('python-pyln-client')
source=('git+https://github.com/ElementsProject/lightning.git'
'git+https://github.com/zserge/jsmn.git'
'git+https://github.com/ianlancetaylor/libbacktrace.git'
@@ -40,6 +41,8 @@ build() {
COPTFLAGS="${CFLAGS}" \
PYTEST=pytest ./configure --prefix=/usr
make LDFLAGS="${LDFLAGS}" libexecdir=/usr/lib
+ cd contrib/pyln-client
+ python -m poetry build --format wheel
}
package() {
@@ -47,4 +50,5 @@ package() {
make DESTDIR="${pkgdir}" libexecdir=/usr/lib install
install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+ python -m installer --destdir="$pkgdir" contrib/pyln-client/dist/*.whl
}