summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 394ecfcb0c05..39981704ef36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Contributor: Nicola Squartini <tensor5@gmail.com>
pkgname=core-lightning-git
-pkgver=23.08rc1.r13429.568f27783
+pkgver=23.08.r13576.990096f90
pkgrel=1
pkgdesc='A lightweight, highly customizable and standard compliant implementation of the Lightning Network protocol.'
arch=('i686' 'x86_64')
url='https://github.com/ElementsProject/lightning'
license=('custom')
-depends=('gmp' 'libsodium' 'sqlite' 'python-grpcio-tools')
-makedepends=('clang' 'git' 'python-pytest' 'python-mako' 'mrkd')
+depends=('gmp' 'libsodium' 'sqlite' 'python-grpcio-tools' 'python-flask' 'python-json5' 'gunicorn' 'python-flask-restx')
+makedepends=('clang' 'git' 'python-pytest' 'python-mako' 'mrkd' 'python-poetry')
+provides=('python-pyln-client')
source=('git+https://github.com/ElementsProject/lightning.git'
'git+https://github.com/zserge/jsmn.git'
'git+https://github.com/ianlancetaylor/libbacktrace.git'
@@ -40,6 +41,8 @@ build() {
COPTFLAGS="${CFLAGS}" \
PYTEST=pytest ./configure --prefix=/usr
make LDFLAGS="${LDFLAGS}" libexecdir=/usr/lib
+ cd contrib/pyln-client
+ python -m poetry build --format wheel
}
package() {
@@ -47,4 +50,5 @@ package() {
make DESTDIR="${pkgdir}" libexecdir=/usr/lib install
install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+ python -m installer --destdir="$pkgdir" contrib/pyln-client/dist/*.whl
}