aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD30
2 files changed, 11 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3350ce8e385d..c48e44f7e367 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = corky
pkgdesc = Some Lua modules for the system monitor Conky.
- pkgver = 2017033001
- pkgrel = 2
- url = https://gitlab.com/goeb/Corky/
+ pkgver = 2019021402
+ pkgrel = 1
+ url = https://gitlab.com/goeb/corky/
install = corky.install
arch = any
license = GPL3
makedepends = git
+ makedepends = ldoc
depends = conky-cairo
depends = lua-lpeg
- source = corky::git+https://gitlab.com/goeb/Corky.git#tag=2017033001
+ source = corky::git+https://gitlab.com/goeb/corky.git#tag=2019021402
sha256sums = SKIP
pkgname = corky
diff --git a/PKGBUILD b/PKGBUILD
index 3d8e23cf6bb1..ebbc54019da1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,22 @@
# Maintainer: Stefan Göbel <aur —at— subtype —dot— de>
pkgname='corky'
-_reponame='Corky'
-pkgver='2017033001'
-pkgrel='2'
+pkgver='2019021402'
+pkgrel='1'
pkgdesc='Some Lua modules for the system monitor Conky.'
-url='https://gitlab.com/goeb/Corky/'
+url='https://gitlab.com/goeb/corky/'
install="$pkgname.install"
arch=('any')
license=('GPL3')
depends=('conky-cairo' 'lua-lpeg')
-makedepends=('git')
-source=("$pkgname::git+https://gitlab.com/goeb/$_reponame.git#tag=$pkgver")
+makedepends=('git' 'ldoc')
+source=("$pkgname::git+https://gitlab.com/goeb/$pkgname.git#tag=$pkgver")
sha256sums=('SKIP')
-prepare() {
-
- cd "$pkgname"
-
- # Change the module's path in the example configuration:
- sed -i 's!"lua/corky.lua"!"/usr/share/lua/5.3/corky.lua"!' 'example/conky.conf'
-
-}
-
package() {
cd "$pkgname"
-
- # Install the modules:
- install -dm 0755 "${pkgdir}/usr/share/lua/5.3"
- cp -a lua/* "${pkgdir}/usr/share/lua/5.3"
-
- # Install the README file and the example:
- install -dm 0755 "${pkgdir}/usr/share/doc/corky"
- cp -a README "${pkgdir}/usr/share/doc/corky"
- cp -a example "${pkgdir}/usr/share/doc/corky"
+ make install DESTDIR="$pkgdir" PREFIX='/usr'
}