summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a633000db87..6ddc4478fce6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cpumanager-git
pkgdesc = CPU controler
- pkgver = 2.2
- pkgrel = 0
+ pkgver = 2.1.r0.g059c46c
+ pkgrel = 1
url = https://github.com/nbebaw/cpumanager-git
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 15816facb58f..20f68e0faca3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Maintainer: Your Name <youremail@domain.com>
pkgname=cpumanager-git
-pkgver=2.2
-pkgrel=0
+pkgver=2.1.r0.g059c46c
+pkgrel=1
#epoch=
pkgdesc="CPU controler"
arch=('any')
@@ -29,6 +29,12 @@ source=("git+https://github.com/nbebaw/cpumanager-git.git")
md5sums=('SKIP')
#validpgpkeys=()
+pkgver() {
+ cd "$pkgname"
+ # cutting off 'foo-' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
#prepare() {
# cd "$pkgname-$pkgver"
# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"