summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15816facb58f..20f68e0faca3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Maintainer: Your Name <youremail@domain.com>
pkgname=cpumanager-git
-pkgver=2.2
-pkgrel=0
+pkgver=2.1.r0.g059c46c
+pkgrel=1
#epoch=
pkgdesc="CPU controler"
arch=('any')
@@ -29,6 +29,12 @@ source=("git+https://github.com/nbebaw/cpumanager-git.git")
md5sums=('SKIP')
#validpgpkeys=()
+pkgver() {
+ cd "$pkgname"
+ # cutting off 'foo-' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
#prepare() {
# cd "$pkgname-$pkgver"
# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"