summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b88e6be6429..d3f9d2ee8939 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = desq-shell
pkgdesc = The Desktop Shell for Desq
pkgver = 0.0.8
- pkgrel = 3
+ pkgrel = 4
url = https://gitlab.com/DesQ/Shell
arch = x86_64
arch = aarch64
@@ -33,9 +33,7 @@ pkgbase = desq-shell
depends = wayfire
depends = wayfire-plugins-extra
depends = wayfire-plugins-wfconfig-hjson
- depends = wayfire-plugins-windecor
depends = wayfire-plugins-dbusqt
- depends = wayfire-plugins-focus-request
depends = wayfire-plugins-desq-shell
depends = wayfire-plugins-toplevel-manager
source = https://gitlab.com/DesQ/Shell/-/archive/v0.0.8/Shell-v0.0.8.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 1ba099b5211d..7876f2f0ab82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,23 +6,23 @@
_pkgname=Shell
pkgname=desq-shell
pkgver=0.0.8
-pkgrel=3
+pkgrel=4
pkgdesc="The Desktop Shell for Desq"
arch=('x86_64' 'aarch64')
url="https://gitlab.com/DesQ/${_pkgname}"
license=('GPL3')
depends=('qt5-base' 'qt5-x11extras' 'libdbusmenu-qt5' 'libxcomposite' 'libdesqui' 'pam' 'qt5-svg' 'wayland-protocols'
'dfl-utils' 'dfl-xdg' 'dfl-ipc' 'dfl-applications' 'dfl-settings' 'dfl-layouts' 'dfl-wayqt' 'dfl-status-notifier'
- 'dfl-hjsonparser' 'dfl-colorschemeparser' 'dfl-power' 'dfl-login1' 'dfl-inotify' 'dfl-volume'
- 'wayfire' 'wayfire-plugins-extra' 'wayfire-plugins-wfconfig-hjson' 'wayfire-plugins-windecor' 'wayfire-plugins-dbusqt'
- 'wayfire-plugins-focus-request' 'wayfire-plugins-desq-shell' 'wayfire-plugins-toplevel-manager')
+ 'dfl-hjsonparser' 'dfl-colorschemeparser' 'dfl-power' 'dfl-login1' 'dfl-inotify' 'dfl-volume' 'wayfire'
+ 'wayfire-plugins-extra' 'wayfire-plugins-wfconfig-hjson' 'wayfire-plugins-dbusqt' 'wayfire-plugins-desq-shell'
+ 'wayfire-plugins-toplevel-manager')
makedepends=('meson' 'ninja')
source=("https://gitlab.com/DesQ/${_pkgname}/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz")
md5sums=('063db58d9f9f062f4f72f562b4852ca8')
build() {
cd "${_pkgname}-v${pkgver}"
- PKG_CONFIG_PATH=/usr/lib/wlroots0.16/pkgconfig meson setup .build --prefix=/usr --buildtype=release
+ meson setup .build --prefix=/usr --buildtype=release
ninja -C .build
}