summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ba099b5211d..7876f2f0ab82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,23 +6,23 @@
_pkgname=Shell
pkgname=desq-shell
pkgver=0.0.8
-pkgrel=3
+pkgrel=4
pkgdesc="The Desktop Shell for Desq"
arch=('x86_64' 'aarch64')
url="https://gitlab.com/DesQ/${_pkgname}"
license=('GPL3')
depends=('qt5-base' 'qt5-x11extras' 'libdbusmenu-qt5' 'libxcomposite' 'libdesqui' 'pam' 'qt5-svg' 'wayland-protocols'
'dfl-utils' 'dfl-xdg' 'dfl-ipc' 'dfl-applications' 'dfl-settings' 'dfl-layouts' 'dfl-wayqt' 'dfl-status-notifier'
- 'dfl-hjsonparser' 'dfl-colorschemeparser' 'dfl-power' 'dfl-login1' 'dfl-inotify' 'dfl-volume'
- 'wayfire' 'wayfire-plugins-extra' 'wayfire-plugins-wfconfig-hjson' 'wayfire-plugins-windecor' 'wayfire-plugins-dbusqt'
- 'wayfire-plugins-focus-request' 'wayfire-plugins-desq-shell' 'wayfire-plugins-toplevel-manager')
+ 'dfl-hjsonparser' 'dfl-colorschemeparser' 'dfl-power' 'dfl-login1' 'dfl-inotify' 'dfl-volume' 'wayfire'
+ 'wayfire-plugins-extra' 'wayfire-plugins-wfconfig-hjson' 'wayfire-plugins-dbusqt' 'wayfire-plugins-desq-shell'
+ 'wayfire-plugins-toplevel-manager')
makedepends=('meson' 'ninja')
source=("https://gitlab.com/DesQ/${_pkgname}/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz")
md5sums=('063db58d9f9f062f4f72f562b4852ca8')
build() {
cd "${_pkgname}-v${pkgver}"
- PKG_CONFIG_PATH=/usr/lib/wlroots0.16/pkgconfig meson setup .build --prefix=/usr --buildtype=release
+ meson setup .build --prefix=/usr --buildtype=release
ninja -C .build
}