summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b42a4bca234a..533f4c269cdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = disk-benchmark
pkgdesc = Tool to benchmark disks, devices, filesystems or even files, like CrystalDiskMark but for the command line
- pkgver = 1.0.0
+ pkgver = r19.a82f4e7
pkgrel = 1
url = https://github.com/rigon/disk-benchmark
arch = i686
@@ -8,9 +8,8 @@ pkgbase = disk-benchmark
arch = arm
arch = armv6h
arch = armv7h
- license = MIT
+ license = GPL3
makedepends = git
- makedepends = gcc
source = git+https://github.com/rigon/disk-benchmark.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 49dfde1e809d..d25e2a6383b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,20 @@
# Maintainer: Ricardo Gonçalves <ricardompgoncalves at gmail dot com>
pkgname=disk-benchmark
-pkgver=1.0.0
+pkgver=r19.a82f4e7
pkgrel=1
pkgdesc="Tool to benchmark disks, devices, filesystems or even files, like CrystalDiskMark but for the command line"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="https://github.com/rigon/disk-benchmark"
-license=('MIT')
-makedepends=('git' 'gcc')
+license=('GPL3')
+makedepends=('git')
source=("git+https://github.com/rigon/disk-benchmark.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd "$pkgname"
gcc -o $pkgname disk-benchmark.c