summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 847339831f2d..c454cd7a2f0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,11 +4,11 @@ pkgbase = dns2tcp-zfl9
pkgrel = 1
url = https://github.com/zfl9/dns2tcp
arch = x86_64
+ arch = aarch64
license = GPL3
provides = dns2tcp
conflicts = dns2tcp
- source = dns2tcp-1.1.0::https://github.com/zfl9/dns2tcp/archive/refs/tags/latest.tar.gz
+ source = dns2tcp-1.1.0::https://github.com/zfl9/dns2tcp/archive/refs/tags/v1.1.0.tar.gz
sha512sums = SKIP
pkgname = dns2tcp-zfl9
-
diff --git a/PKGBUILD b/PKGBUILD
index 847a98558662..e52f3dc12ffc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,21 +5,21 @@ _pkgbase=dns2tcp
pkgver=1.1.0
pkgrel=1
pkgdesc='utility to convert dns query from udp to tcp'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/zfl9/dns2tcp"
license=('GPL3')
conflicts=('dns2tcp')
provides=('dns2tcp')
depends=()
-source=("$_pkgbase-$pkgver::https://github.com/zfl9/dns2tcp/archive/refs/tags/latest.tar.gz")
+source=("$_pkgbase-$pkgver::https://github.com/zfl9/dns2tcp/archive/refs/tags/v${pkgver}.tar.gz")
sha512sums=('SKIP')
build() {
- cd $_pkgbase-latest
+ cd $_pkgbase-${pkgver}
make DESTDIR=/usr/bin
}
package() {
- cd $_pkgbase-latest
+ cd $_pkgbase-${pkgver}
make DESTDIR=$pkgdir/usr/bin/ install
}