summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ceff9bfbbbb8..c2a0596ca17c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = emacs-with-editor
- pkgdesc = Use the Emacsclient as the of child processes
- pkgver = 2.8.3
+ pkgdesc = Use the Emacsclient as the vim of child processes
+ pkgver = 3.0.4
pkgrel = 1
url = http://github.com/magit/with-editor
install = emacs-with-editor.install
arch = any
license = GPL3
- depends = emacs>=24.4
- depends = emacs-async>=1.9
+ depends = emacs
+ depends = emacs-async
provides = emacs-with-editor
conflicts = emacs-with-editor-git
- source = git+https://github.com/magit/with-editor.git#tag=v2.8.3
- md5sums = SKIP
+ source = https://github.com/magit/with-editor/archive/refs/tags/v3.0.4.tar.gz
+ sha256sums = 1e5001cb0793f7d3e17d83121f557d7586f8c3760e71f5cfc3fdcf5057712c50
pkgname = emacs-with-editor
-
diff --git a/PKGBUILD b/PKGBUILD
index deb529cf9726..58684037e4da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Esben Haabendal <esben@haabendal.dk>
pkgname=emacs-with-editor
-pkgver=2.8.3
+pkgver=3.0.4
pkgrel=1
pkgdesc="Use the Emacsclient as the $EDITOR of child processes"
arch=('any')
@@ -9,23 +9,23 @@ _github_org="magit"
_github_repo="with-editor"
url="http://github.com/${_github_org}/${_github_repo}"
license=('GPL3')
-makedepends=('git')
-depends=('emacs' 'emacs-async>=1.9')
+makedepends=()
+depends=('emacs' 'emacs-async')
provides=('emacs-with-editor')
conflicts=('emacs-with-editor-git')
install="${pkgname}.install"
-source=("git+https://github.com/${_github_org}/${_github_repo}.git#tag=v$pkgver")
-md5sums=('SKIP')
+source=("https://github.com/${_github_org}/${_github_repo}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('1e5001cb0793f7d3e17d83121f557d7586f8c3760e71f5cfc3fdcf5057712c50')
build() {
- cd "$srcdir/${_github_repo}"
+ cd "$srcdir/${_github_repo}-${pkgver}"
unset EMACS
make EFLAGS="-L /usr/share/emacs/site-lisp -L ${srcdir}/${_gitrepo}/lisp" \
lisp info
}
package() {
- cd "$srcdir/${_github_repo}"
+ cd "$srcdir/${_github_repo}-${pkgver}"
mkdir -p ${pkgdir}/usr/share/emacs/site-lisp
install -m 644 with-editor.{el,elc} ${pkgdir}/usr/share/emacs/site-lisp
mkdir -p ${pkgdir}/usr/share/info