summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index deb529cf9726..58684037e4da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Esben Haabendal <esben@haabendal.dk>
pkgname=emacs-with-editor
-pkgver=2.8.3
+pkgver=3.0.4
pkgrel=1
pkgdesc="Use the Emacsclient as the $EDITOR of child processes"
arch=('any')
@@ -9,23 +9,23 @@ _github_org="magit"
_github_repo="with-editor"
url="http://github.com/${_github_org}/${_github_repo}"
license=('GPL3')
-makedepends=('git')
-depends=('emacs' 'emacs-async>=1.9')
+makedepends=()
+depends=('emacs' 'emacs-async')
provides=('emacs-with-editor')
conflicts=('emacs-with-editor-git')
install="${pkgname}.install"
-source=("git+https://github.com/${_github_org}/${_github_repo}.git#tag=v$pkgver")
-md5sums=('SKIP')
+source=("https://github.com/${_github_org}/${_github_repo}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('1e5001cb0793f7d3e17d83121f557d7586f8c3760e71f5cfc3fdcf5057712c50')
build() {
- cd "$srcdir/${_github_repo}"
+ cd "$srcdir/${_github_repo}-${pkgver}"
unset EMACS
make EFLAGS="-L /usr/share/emacs/site-lisp -L ${srcdir}/${_gitrepo}/lisp" \
lisp info
}
package() {
- cd "$srcdir/${_github_repo}"
+ cd "$srcdir/${_github_repo}-${pkgver}"
mkdir -p ${pkgdir}/usr/share/emacs/site-lisp
install -m 644 with-editor.{el,elc} ${pkgdir}/usr/share/emacs/site-lisp
mkdir -p ${pkgdir}/usr/share/info