summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 783e7a0ee04f..46da6bd57650 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = eontimer-git
pkgdesc = A Pokemon RNG timer
- pkgver = 2.0.1
+ pkgver = r55.d53e42a
pkgrel = 1
url = https://github.com/dylmeadows/EonTimer
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = eontimer-git
depends = sfml
provides = eontimer
conflicts = eontimer
- source = eontimer-git-2.0.1::git+https://github.com/dylmeadows/EonTimer.git
+ source = eontimer-git-r55.d53e42a::git+https://github.com/dylmeadows/EonTimer.git
sha256sums = SKIP
pkgname = eontimer-git
diff --git a/PKGBUILD b/PKGBUILD
index 4e91c7423318..e0576371ca81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=EonTimer
pkgname=eontimer-git
-pkgver=2.0.1
+pkgver=r55.d53e42a
pkgrel=1
pkgdesc='A Pokemon RNG timer'
arch=(x86_64)
@@ -23,6 +23,15 @@ provides=('eontimer')
source=("$pkgname-$pkgver::git+https://github.com/dylmeadows/EonTimer.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$pkgname-$pkgver"
+ # Technically, version 3.0 is in development at the time of writing, but the
+ # earlier 2.*-tags are not reachable anymore. Since `git describe` won't
+ # work, we fall back to counting revisions. This is forward compatible with
+ # future versions `v3.*.*`.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
prepare() {
cd $pkgname-$pkgver
python3 -m qtsass -o resources/styles resources/styles