summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e91c7423318..e0576371ca81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=EonTimer
pkgname=eontimer-git
-pkgver=2.0.1
+pkgver=r55.d53e42a
pkgrel=1
pkgdesc='A Pokemon RNG timer'
arch=(x86_64)
@@ -23,6 +23,15 @@ provides=('eontimer')
source=("$pkgname-$pkgver::git+https://github.com/dylmeadows/EonTimer.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$pkgname-$pkgver"
+ # Technically, version 3.0 is in development at the time of writing, but the
+ # earlier 2.*-tags are not reachable anymore. Since `git describe` won't
+ # work, we fall back to counting revisions. This is forward compatible with
+ # future versions `v3.*.*`.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
prepare() {
cd $pkgname-$pkgver
python3 -m qtsass -o resources/styles resources/styles