summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rwxr-xr-xbuild_installer.sh18
-rwxr-xr-xbuild_lite_installer.sh24
-rw-r--r--evesetup.changelog8
-rw-r--r--setup.sh.in37
-rw-r--r--setup_lite.sh.in19
7 files changed, 72 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3df8521ea84..2e64aa4db34d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -75,10 +75,10 @@ pkgbase = evesetup
sha256sums = 261da84107168979d241c60cd7adbfee0f6675464675faaefd5f6140009d54d8
sha256sums = 609c021ee09ced450b1aeda9c3dd586ebfbc17d2bdccbb4be69de70d661d12c8
sha256sums = c53c6f09a0d2d12a4360bc4283d6259de1f47cfc29f708fdd9b960aab30af4ef
- sha256sums = c9276c42973b1b7cfa851ef9109a40c70ca5d4ec918fd20fb9dfc90cb02c7b60
- sha256sums = 565cb6803fd6802233e6329aae1742413034222df9d6d3add6334f26cecc4439
- sha256sums = 60b6f5175916c40ed355ef29fb637743227a2b25c446a9239df69d320f2667fa
- sha256sums = 4e9083c96ada9c607b12fc1be77db595a6932d01d7c6b224a3c546aa98f37b32
+ sha256sums = 675da37e1a26862914fb7900c974892ecdd8946c53ff96d322c204f5e410d14a
+ sha256sums = eae205aeb9078d1e2ebed6d7260e104051650c9f20affa16742c44eb41f5a4c0
+ sha256sums = dbe32af6b0925fe110aa91a7d49337083a16010fc0d1c3bad17acec06f7e47f1
+ sha256sums = 6b1d665ba4187f265d04c5b34506d52e72dbb36ba1b9583e7cc30b5757e70f9e
sha256sums = 69b98d923c08c6fb035c0c6905ec5e9c73273b694f8f3497777d44597dbe63e3
sha256sums = 762db1df07dfcf526fe634b4b589a08e8affefb2f79f02cff2624c70e0820422
sha256sums = 980d68abd6f4a662b69efd19145112e88f349044fa1ed5cb6d0a840a92cb42e4
diff --git a/PKGBUILD b/PKGBUILD
index 15f80c31adde..51b6331d7cda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -139,10 +139,10 @@ sha256sums=('ce85defa2698ea72e88221d72424fb953f86836494ecc0e4006f41ec89682af4'
'261da84107168979d241c60cd7adbfee0f6675464675faaefd5f6140009d54d8'
'609c021ee09ced450b1aeda9c3dd586ebfbc17d2bdccbb4be69de70d661d12c8'
'c53c6f09a0d2d12a4360bc4283d6259de1f47cfc29f708fdd9b960aab30af4ef'
- 'c9276c42973b1b7cfa851ef9109a40c70ca5d4ec918fd20fb9dfc90cb02c7b60'
- '565cb6803fd6802233e6329aae1742413034222df9d6d3add6334f26cecc4439'
- '60b6f5175916c40ed355ef29fb637743227a2b25c446a9239df69d320f2667fa'
- '4e9083c96ada9c607b12fc1be77db595a6932d01d7c6b224a3c546aa98f37b32'
+ '675da37e1a26862914fb7900c974892ecdd8946c53ff96d322c204f5e410d14a'
+ 'eae205aeb9078d1e2ebed6d7260e104051650c9f20affa16742c44eb41f5a4c0'
+ 'dbe32af6b0925fe110aa91a7d49337083a16010fc0d1c3bad17acec06f7e47f1'
+ '6b1d665ba4187f265d04c5b34506d52e72dbb36ba1b9583e7cc30b5757e70f9e'
'69b98d923c08c6fb035c0c6905ec5e9c73273b694f8f3497777d44597dbe63e3'
'762db1df07dfcf526fe634b4b589a08e8affefb2f79f02cff2624c70e0820422'
'980d68abd6f4a662b69efd19145112e88f349044fa1ed5cb6d0a840a92cb42e4'
diff --git a/build_installer.sh b/build_installer.sh
index 4ecc91cc32af..acad9f92bfa3 100755
--- a/build_installer.sh
+++ b/build_installer.sh
@@ -24,16 +24,20 @@ dvcsum=$(csum dxvk-$dvver.tar.gz)
elcsum=$(csum evelauncher-\${pkgver}.tar.gz)
mscsum=$(csum makeself-$msver.run)
-if [ ! -x "$(which curl 2>/dev/null)" ] ;then
- printf "\nError: Curl not found. Curl are needed for downloading makeself build tool."
- printf "\n\tPlease install curl with your Package Manager.\n"
- printf "\nLeaving.\n\n"
- exit 0
-fi
+dltool=$(which curl 2>/dev/null || which wget 2>/dev/null || true)
+
+case ${dltool##*/} in
+ curl) dltool="$dltool -L -O" ;;
+ wget) dltool="$dltool -nc" ;;
+ *) printf "\nError: curl or wget not found. One of them are needed for downloading makeself build tool."
+ printf "\n Please install curl or wget with your Package Manager.\n"
+ printf "\nLeaving.\n\n"
+ exit 0 ;;
+esac
if [ ! -f "./makeself-$msver.run" ] ;then
printf "\nGet makeself...\n\n"
- curl -L -O https://github.com/megastep/makeself/releases/download/release-$msver/makeself-$msver.run
+ $dltool https://github.com/megastep/makeself/releases/download/release-$msver/makeself-$msver.run
fi
rcsum="$(sha256sum ./makeself-$msver.run | cut -d' ' -f1)"
if [ "$rcsum" != "$mscsum" ] ;then
diff --git a/build_lite_installer.sh b/build_lite_installer.sh
index 8479f652cd25..484844a0c565 100755
--- a/build_lite_installer.sh
+++ b/build_lite_installer.sh
@@ -24,16 +24,20 @@ dvcsum=$(csum dxvk-$dvver.tar.gz)
elcsum=$(csum evelauncher-\${pkgver}.tar.gz)
mscsum=$(csum makeself-$msver.run)
-if [ ! -x "$(which curl 2>/dev/null)" ] ;then
- printf "\nError: Curl not found. Curl are needed for downloading makeself build tool."
- printf "\n\tPlease install curl with your Package Manager.\n"
- printf "\nLeaving.\n\n"
- exit 0
-fi
+dltool=$(which curl2 2>/dev/null || which wget 2>/dev/null || true)
+
+case ${dltool##*/} in
+ curl) dltool="$dltool -L -O" ;;
+ wget) dltool="$dltool -nc" ;;
+ *) printf "\nError: curl or wget not found. One of them are needed for downloading makeself build tool."
+ printf "\n Please install curl or wget with your Package Manager.\n"
+ printf "\nLeaving.\n\n"
+ exit 0 ;;
+esac
if [ ! -f "./makeself-$msver.run" ] ;then
printf "\nGet makeself...\n\n"
- curl -L -O https://github.com/megastep/makeself/releases/download/release-$msver/makeself-$msver.run
+ $dltool https://github.com/megastep/makeself/releases/download/release-$msver/makeself-$msver.run
fi
rcsum="$(sha256sum ./makeself-$msver.run | cut -d' ' -f1)"
if [ "$rcsum" != "$mscsum" ] ;then
@@ -44,7 +48,7 @@ fi
if [ ! -r "./evelauncher-$version.tar.gz" ] ;then
printf "\nGet evelauncher-$version.tar.gz...\n\n"
- curl -L -O https://binaries.eveonline.com/evelauncher-$version.tar.gz
+ $dltool https://binaries.eveonline.com/evelauncher-$version.tar.gz
fi
rcsum="$(sha256sum ./evelauncher-$version.tar.gz| cut -d' ' -f1)"
if [ "$rcsum" != "$elcsum" ] ;then
@@ -54,8 +58,8 @@ if [ "$rcsum" != "$elcsum" ] ;then
fi
if [ ! -r "./dxvk-$dvver.tar.gz" ] ;then
- printf "\nDownload dxvk-$dvver.tar.gz...\n\n"
- curl -L -O https://github.com/doitsujin/dxvk/releases/download/v$dvver/dxvk-$dvver.tar.gz
+ printf "\nGet dxvk-$dvver.tar.gz...\n\n"
+ $dltool https://github.com/doitsujin/dxvk/releases/download/v$dvver/dxvk-$dvver.tar.gz
fi
rcsum="$(sha256sum ./dxvk-$dvver.tar.gz| cut -d' ' -f1)"
if [ "$rcsum" != "$dvcsum" ] ;then
diff --git a/evesetup.changelog b/evesetup.changelog
index a3cdd675aa0a..a971c65847d0 100644
--- a/evesetup.changelog
+++ b/evesetup.changelog
@@ -1,6 +1,4 @@
-In build scripts checksum routine added and minor changes.
+In build scripts checksum routine and minor changes added.
+Wget as alternative to curl in build and setup scripts added.
+Installation with missing requirements added (temporary solution, not final).
Enabled DX11 mode as default in evesetup.shlib in eve environment function.
-
-
-
-
diff --git a/setup.sh.in b/setup.sh.in
index 9c54761db403..16edc04f5454 100644
--- a/setup.sh.in
+++ b/setup.sh.in
@@ -73,7 +73,7 @@ bootstrap_remove() {
build_lib() {
if [ ! -r "./evelauncher-$elver.tar.gz" ] ;then
printf "\nDownload evelauncher-$elver.tar.gz...\n\n"
- curl -L -O https://binaries.eveonline.com/evelauncher-$elver.tar.gz
+ $dltool https://binaries.eveonline.com/evelauncher-$elver.tar.gz
fi
rcsum="$(sha256sum ./evelauncher-$elver.tar.gz| cut -d' ' -f1)"
if [ "$rcsum" != "$elcsum" ] ;then
@@ -81,7 +81,7 @@ build_lib() {
printf "\nLeaving.\n\n"
exit 0
fi
- printf "\n\nExtract evelauncher-$elver.tar.gz..."
+ printf "\nExtract evelauncher-$elver.tar.gz..."
tar xf evelauncher-$elver.tar.gz
echo "done."
printf "\nClean up evelauncher directory..."
@@ -118,13 +118,13 @@ build_lib() {
rm evelauncher-$elver.tar.gz
tar czf evelauncher-$elver.tar.gz evelauncher/
rm -rf evelauncher/
- echo "done."
+ printf "done.\n\n"
}
get_dxvk() {
if [ ! -r "./dxvk-$dvver.tar.gz" ] ;then
printf "\nDownload dxvk-$dvver.tar.gz...\n\n"
- curl -L -O https://github.com/doitsujin/dxvk/releases/download/v$dvver/dxvk-$dvver.tar.gz
+ $dltool https://github.com/doitsujin/dxvk/releases/download/v$dvver/dxvk-$dvver.tar.gz
fi
rcsum="$(sha256sum ./dxvk-$dvver.tar.gz| cut -d' ' -f1)"
if [ "$rcsum" != "$dvcsum" ] ;then
@@ -134,24 +134,34 @@ get_dxvk() {
}
check_req() {
- if [ ! -r "$(find /usr/lib -type f -name 'libxcb-xinerama*' 2>/dev/null)" ] ;then
- req="${req}libxcb-xinerama\n"
- fi
+ case ${dltool##*/} in
+ curl) dltool="$dltool -L -O" ;;
+ wget) dltool="$dltool -nc" ;;
+ *) printf "\nError: curl or wget not found. One of them are needed for downloading sources."
+ printf "\n Please install curl or wget with your Package Manager.\n"
+ printf "\nLeaving.\n\n"
+ exit 0 ;;
+ esac
if [ ! -x "$(which 7z 2>/dev/null)" ] ;then
req="${req}7z\n"
fi
- if [ ! -x "$(which curl 2>/dev/null)" ] ;then
- req="${req}curl\n"
+ if [ ! -x "$(which lsof 2>/dev/null)" ] ;then
+ req="${req}lsof\n"
fi
if [ ! -x "$(which wine 2>/dev/null)" ] ;then
req="${req}wine\n"
fi
+ if [ ! -r "$(find /usr/lib -type f -name 'libxcb-xinerama*' 2>/dev/null)" ] ;then
+ req="${req}libxcb-xinerama\n"
+ fi
if [ "x$req" != "x" ] ;then
printf "\nError: Following requirements are missing:\n"
printf "\n$req\n"
- printf "\nPlease install these requirements with your Package Manager.\n"
- printf "\nLeaving.\n\n"
- exit 0
+ read -p 'Install anyway? (y/N) ' key
+ if [ "x$(echo $key | tr [:upper:] [:lower:])" != "xy" ] ;then
+ printf "\nLeaving.\n\n"
+ exit 0
+ fi
fi
}
@@ -168,6 +178,8 @@ dvcsum=""
rcsum=""
key=""
+dltool=$(which curl 2>/dev/null || which wget 2>/dev/null || true)
+
if [ $(id -u) -ne 0 ] ;then
printf "\nEVE Online Launcher Setup need root permissions."
printf "\nLeaving.\n\n"
@@ -189,7 +201,6 @@ else
check_req
build_lib
get_dxvk
- printf "\n"
bootstrap_install
printf "\nYou can now start EVE Online Launcher and his Tools:\n\n"
for cmd in *.desktop ;do
diff --git a/setup_lite.sh.in b/setup_lite.sh.in
index d76aed99575b..73c49a55cb47 100644
--- a/setup_lite.sh.in
+++ b/setup_lite.sh.in
@@ -67,26 +67,31 @@ bootstrap_remove() {
}
check_req() {
- if [ ! -r "$(find /usr/lib -type f -name 'libxcb-xinerama*' 2>/dev/null)" ] ;then
- req="${req}libxcb-xinerama\n"
- fi
if [ ! -x "$(which 7z 2>/dev/null)" ] ;then
req="${req}7z\n"
fi
+ if [ ! -x "$(which lsof 2>/dev/null)" ] ;then
+ req="${req}lsof\n"
+ fi
if [ ! -x "$(which wine 2>/dev/null)" ] ;then
req="${req}wine\n"
fi
+ if [ ! -r "$(find /usr/lib -type f -name 'libxcb-xinerama*' 2>/dev/null)" ] ;then
+ req="${req}libxcb-xinerama\n"
+ fi
tar xf evelauncher-$elver.tar.gz
cd evelauncher/
- req="${req}$(LD_LIBRARY_PATH=$(pwd) ldd ./evelauncher | grep -i not | sed 's,\t,,;s,.so.*,,')"
+ req="${req}$(LD_LIBRARY_PATH=$(pwd) ldd ./evelauncher | grep -i not | sed 's,\t,,;s,.so.*,,')\n"
cd ../
rm -rf evelauncher/
if [ "x$req" != "x" ] ;then
printf "\nError: Following requirements are missing:\n"
printf "\n$req\n"
- printf "\nPlease install these requirements with your Package Manager.\n"
- printf "\nLeaving.\n\n"
- exit 0
+ read -p 'Install anyway? (y/N) ' key
+ if [ "x$(echo $key | tr [:upper:] [:lower:])" != "xy" ] ;then
+ printf "\nLeaving.\n\n"
+ exit 0
+ fi
fi
}