summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
-rwxr-xr-xbuild_installer.sh2
-rw-r--r--evelauncher.sh13
-rw-r--r--evelauncher.sh.in13
-rw-r--r--everegedit18
-rw-r--r--evewine19
-rw-r--r--evewinecfg18
-rw-r--r--evewinetricks17
-rw-r--r--setup.sh.in55
10 files changed, 93 insertions, 100 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9960d983bfd6..0a6c5aafd574 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -31,10 +31,8 @@ pkgbase = evesetup
source = evelauncher.sh.in
source = evelauncher.sh.real
source = everegedit.desktop
- source = everegedit
source = evewine
source = evewinecfg.desktop
- source = evewinecfg
source = evewinetricks.desktop
source = evewinetricks
source = qt.conf
@@ -49,19 +47,17 @@ pkgbase = evesetup
source = https://github.com/megastep/makeself/releases/download/release-2.4.0/makeself-2.4.0.run
source = https://binaries.eveonline.com/evelauncher-1385477.tar.gz
sha256sums = f49b404341e1dd48eaa2504c83f9ff07c9a4c11e1a109c67d04167dc70d65731
- sha256sums = e86dead05b42cfeb0e5be9a2b06e981accc4926e0442eaf382c872d0ec57d157
- sha256sums = 1932e9cbd3fdda9ec0b5fcbab9aebefc5abe85ad466fc22ed72cc7ae0676b246
+ sha256sums = bd00eb9884f858f6f89ca4d84ac0ad3561e0c93f730ba0336d7df18bf2d21d82
+ sha256sums = 6d0822615ed29b8ff5b179f2561a034874115e736d034f4103b5ef4864734801
sha256sums = 80fceef0e28c2291cd4ba3924410211edd188717be093ffc329d18697583bd21
sha256sums = f8988be390204ce645ca37f43cdb8e395970f8d6dd36095acf08c5c7cf72833c
- sha256sums = 48e721212248e49da4dfe7b63c7f52258933018022c001722077fb44738891ee
- sha256sums = 9c1e16755e548f94c56a3d88110d8ee0d2eb2575d1e0ffe900d4cffdc7820f09
+ sha256sums = f0fef94e2963138ee68a736376a29513426b415aa43fcba8794322778f62c939
sha256sums = 04d2a47524cbd132aad2fd310d56515a29310a2e693ba94ce12c65cd776a70d2
- sha256sums = a665439ed2de7ade9db67ca5859c1dafaad49a9cd1f64612252fcc243b8afd6c
sha256sums = 22690e393ee89703b17898038aaa37900805104e8c960b346fe1f6050edc9bce
- sha256sums = 0831f3a475326d81c64b10570453ce591d77b4249a6c9ee938f7b79285332748
+ sha256sums = efac7e7f31af0020f35aa026c6231fbf8dd56124832b8d60c3fcde126ca24cab
sha256sums = 2520a9b19f2827fa2634ea2acae3a6f61e73aada1af0eb2029e95709f0c8927d
- sha256sums = 0256b96726ee1c969cacd0cfef68413f46079bda897753552679201f5db99026
- sha256sums = 1e899a90ce1e4cc8dea10d35ba5afab9333ad8cb421964110d3156ff7cde3a1d
+ sha256sums = 1f490852b26b3580e291761946775016dd1c06f2a49cb552e255520d73c23916
+ sha256sums = ab2c35d9a451a545f973efda55a34bbcbb53fb8031a9625e68bc7bb005fde9e1
sha256sums = 2c192fdc282fefafee5596b60bd1779668b611d386e2bf933eef51d39eac7a28
sha256sums = 47accd49b64d624c6a6dee42952f8627aaabdd315fad85ef037507745d393f1a
sha256sums = 1c3df28324c8498e34d2e789fd1f36577afa5a31bdbb278d752f7ef8c6ec5516
diff --git a/PKGBUILD b/PKGBUILD
index 4f72e3f66310..3ce8b6717dea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,10 +30,8 @@ source=("evelauncher.desktop"
"evelauncher.sh.in"
"evelauncher.sh.real"
"everegedit.desktop"
- "everegedit"
"evewine"
"evewinecfg.desktop"
- "evewinecfg"
"evewinetricks.desktop"
"evewinetricks"
"qt.conf"
@@ -60,7 +58,11 @@ package() {
install -d "${pkgdir}/usr/bin"
install -d "${pkgdir}/usr/share/applications"
for cmd in evelauncher.sh everegedit evewine evewinecfg evewinetricks ;do
- install "${srcdir}/$cmd" "${pkgdir}/opt/${pkgname}/bin"
+ if [ -f "${srcdir}/$cmd" ] ;then
+ install "${srcdir}/$cmd" "${pkgdir}/opt/${pkgname}/bin"
+ else
+ ln -s evewine "${pkgdir}/opt/${pkgname}/bin/$cmd"
+ fi
ln -s "/opt/${pkgname}/bin/$cmd" "${pkgdir}/usr/bin/$cmd"
if [ ! "$cmd" = "evewine" ] ;then
cp "${srcdir}/${cmd%.*}.desktop" "${pkgdir}/usr/share/applications/"
@@ -98,19 +100,17 @@ package() {
}
sha256sums=('f49b404341e1dd48eaa2504c83f9ff07c9a4c11e1a109c67d04167dc70d65731'
- 'e86dead05b42cfeb0e5be9a2b06e981accc4926e0442eaf382c872d0ec57d157'
- '1932e9cbd3fdda9ec0b5fcbab9aebefc5abe85ad466fc22ed72cc7ae0676b246'
+ 'bd00eb9884f858f6f89ca4d84ac0ad3561e0c93f730ba0336d7df18bf2d21d82'
+ '6d0822615ed29b8ff5b179f2561a034874115e736d034f4103b5ef4864734801'
'80fceef0e28c2291cd4ba3924410211edd188717be093ffc329d18697583bd21'
'f8988be390204ce645ca37f43cdb8e395970f8d6dd36095acf08c5c7cf72833c'
- '48e721212248e49da4dfe7b63c7f52258933018022c001722077fb44738891ee'
- '9c1e16755e548f94c56a3d88110d8ee0d2eb2575d1e0ffe900d4cffdc7820f09'
+ 'f0fef94e2963138ee68a736376a29513426b415aa43fcba8794322778f62c939'
'04d2a47524cbd132aad2fd310d56515a29310a2e693ba94ce12c65cd776a70d2'
- 'a665439ed2de7ade9db67ca5859c1dafaad49a9cd1f64612252fcc243b8afd6c'
'22690e393ee89703b17898038aaa37900805104e8c960b346fe1f6050edc9bce'
- '0831f3a475326d81c64b10570453ce591d77b4249a6c9ee938f7b79285332748'
+ 'efac7e7f31af0020f35aa026c6231fbf8dd56124832b8d60c3fcde126ca24cab'
'2520a9b19f2827fa2634ea2acae3a6f61e73aada1af0eb2029e95709f0c8927d'
- '0256b96726ee1c969cacd0cfef68413f46079bda897753552679201f5db99026'
- '1e899a90ce1e4cc8dea10d35ba5afab9333ad8cb421964110d3156ff7cde3a1d'
+ '1f490852b26b3580e291761946775016dd1c06f2a49cb552e255520d73c23916'
+ 'ab2c35d9a451a545f973efda55a34bbcbb53fb8031a9625e68bc7bb005fde9e1'
'2c192fdc282fefafee5596b60bd1779668b611d386e2bf933eef51d39eac7a28'
'47accd49b64d624c6a6dee42952f8627aaabdd315fad85ef037507745d393f1a'
'1c3df28324c8498e34d2e789fd1f36577afa5a31bdbb278d752f7ef8c6ec5516'
diff --git a/build_installer.sh b/build_installer.sh
index df03785153de..136aedf3a797 100755
--- a/build_installer.sh
+++ b/build_installer.sh
@@ -29,7 +29,7 @@ printf "\nCopy needed files from AUR package..."
tar xf ../eve-icons.tar.gz -C evesetup/
for eta in $(ls ../eve-transl5.11-??.tar.gz) ;do cp $eta evesetup/ ;done
for cmd in evelauncher.sh everegedit evewine evewinecfg evewinetricks ;do
- cp ../$cmd evesetup/
+ if [ -f ../$cmd ] ;then cp ../$cmd evesetup/ ;fi
if [ ! "$cmd" = "evewine" ] ;then
cp ../${cmd%.*}.desktop evesetup/
fi
diff --git a/evelauncher.sh b/evelauncher.sh
index 89dbbcfa45de..0772a32d51af 100644
--- a/evelauncher.sh
+++ b/evelauncher.sh
@@ -44,17 +44,18 @@ check_wine() {
EVECONF=$CONFDIR/EVE.conf
UCW=$(grep UseCustomWine $EVECONF | cut -d= -f2)
if [ "x$UCW" = "xtrue" ] ;then
- WINEPATH=$(grep CustomWinePath $EVECONF | cut -d= -f2)
- WINEPATH=${WINEPATH%/*}
+ CUSTOMWP=$(grep CustomWinePath $EVECONF | cut -d= -f2)
+ WINEPATH=${CUSTOMWP%/*}
+ SHAREDIR=$(grep SharedCacheFolder $EVECONF | cut -d= -f2)
+ WINEPREFIX=${SHAREDIR}wineenv
else
- launcher_msg "Error: Custom wine not set!"
+ launcher_msg "ERROR: \"Use custom Wine\" not set!"
exit 1
fi
WINEDATE=$(ls -l --time-style=+%s $WINEPATH/wineserver | cut -d' ' -f6)
- INSTWINE=$(cat $EVEDIR/SharedCache/wineenv/.update-timestamp 2>/dev/null) || true
+ INSTWINE=$(cat $WINEPREFIX/.update-timestamp 2>/dev/null) || true
if [ "x$WINEDATE" != "x$INSTWINE" ] ;then
if [ -x "$WINEPATH/wine" ] ;then
- WINEPREFIX=$EVEDIR/SharedCache/wineenv
launcher_msg "Preparing/Updating wine in $WINEPREFIX"
env WINEARCH=win32 \
WINEPREFIX=$WINEPREFIX \
@@ -70,7 +71,7 @@ check_wine() {
env WINEPREFIX=$WINEPREFIX WINE=$WINEPATH/wine \
$(which winetricks) -q winxp >/dev/null
else
- launcher_msg "Error: No wine in $WINEPATH found!"
+ launcher_msg "ERROR: \"$CUSTOMWP\" in \"Custom Wine path\" not found!"
exit 1
fi
fi
diff --git a/evelauncher.sh.in b/evelauncher.sh.in
index 228ff1faf3e3..5b18bc8dd3d9 100644
--- a/evelauncher.sh.in
+++ b/evelauncher.sh.in
@@ -55,17 +55,18 @@ check_wine() {
EVECONF=$CONFDIR/EVE.conf
UCW=$(grep UseCustomWine $EVECONF | cut -d= -f2)
if [ "x$UCW" = "xtrue" ] ;then
- WINEPATH=$(grep CustomWinePath $EVECONF | cut -d= -f2)
- WINEPATH=${WINEPATH%/*}
+ CUSTOMWP=$(grep CustomWinePath $EVECONF | cut -d= -f2)
+ WINEPATH=${CUSTOMWP%/*}
+ SHAREDIR=$(grep SharedCacheFolder $EVECONF | cut -d= -f2)
+ WINEPREFIX=${SHAREDIR}wineenv
else
- launcher_msg "Error: Custom wine not set!"
+ launcher_msg "ERROR: \"Use custom Wine\" not set!"
exit 1
fi
WINEDATE=$(ls -l --time-style=+%s $WINEPATH/wineserver | cut -d' ' -f6)
- INSTWINE=$(cat $EVEDIR/SharedCache/wineenv/.update-timestamp 2>/dev/null) || true
+ INSTWINE=$(cat $WINEPREFIX/.update-timestamp 2>/dev/null) || true
if [ "x$WINEDATE" != "x$INSTWINE" ] ;then
if [ -x "$WINEPATH/wine" ] ;then
- WINEPREFIX=$EVEDIR/SharedCache/wineenv
launcher_msg "Preparing/Updating wine in $WINEPREFIX"
env WINEARCH=win32 \
WINEPREFIX=$WINEPREFIX \
@@ -81,7 +82,7 @@ check_wine() {
env WINEPREFIX=$WINEPREFIX WINE=$WINEPATH/wine \
$(which winetricks) -q winxp >/dev/null
else
- launcher_msg "Error: No wine in $WINEPATH found!"
+ launcher_msg "ERROR: \"$CUSTOMWP\" in \"Custom Wine path\" not found!"
exit 1
fi
fi
diff --git a/everegedit b/everegedit
deleted file mode 100644
index d7d23e29672a..000000000000
--- a/everegedit
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-EVECONF=$HOME/.config/CCP/EVE.conf
-EVEDIR=$HOME/.local/lib/EVE
-
-UCW=$(grep UseCustomWine $EVECONF | cut -d= -f2)
-if [ "x$UCW" = "xtrue" ] ;then
- WINEPATH=$(grep CustomWinePath $EVECONF | cut -d= -f2)
- WINEPATH=${WINEPATH%/*}
-else
- echo "$(basename $0): Error: Custom wine not set!"
- exit 1
-fi
-
-env WINEPREFIX=$HOME/.local/lib/EVE/SharedCache/wineenv \
- WINEDEBUG=-all \
- WINEDLLOVERRIDES="mscoree,mshtml,winemenubuilder.exe=d" \
- $WINEPATH/regedit "$@"
diff --git a/evewine b/evewine
index f4243e28f96e..4bb6b3cc176c 100644
--- a/evewine
+++ b/evewine
@@ -1,18 +1,23 @@
#!/bin/sh
EVECONF=$HOME/.config/CCP/EVE.conf
-EVEDIR=$HOME/.local/lib/EVE
-
UCW=$(grep UseCustomWine $EVECONF | cut -d= -f2)
if [ "x$UCW" = "xtrue" ] ;then
- WINEPATH=$(grep CustomWinePath $EVECONF | cut -d= -f2)
- WINEPATH=${WINEPATH%/*}
+ CUSTOMWP=$(grep CustomWinePath $EVECONF | cut -d= -f2)
+ WINEPATH=${CUSTOMWP%/*}
+ SHAREDIR=$(grep SharedCacheFolder $EVECONF | cut -d= -f2)
+ WINEPREFIX=${SHAREDIR}wineenv
else
- echo "$(basename $0): Error: Custom wine not set!"
+ echo "$(basename $0): ERROR: \"Use Custom Wine\" not set!"
+ exit 1
+fi
+if [ ! -x "$WINEPATH/wine" ] ;then
+ echo "$(basename $0): ERROR: \"$CUSTOMWP\" from \"Custom Wine path\" not found!"
+ echo "$(basename $0): The full path are required (example: /usr/bin/wine)."
exit 1
fi
-env WINEPREFIX=$HOME/.local/lib/EVE/SharedCache/wineenv \
+env WINEPREFIX=$WINEPREFIX \
WINEDEBUG=-all \
WINEDLLOVERRIDES="mscoree,mshtml,winemenubuilder.exe=d" \
- $WINEPATH/wine "$@"
+ $WINEPATH/${0#*eve} "$@"
diff --git a/evewinecfg b/evewinecfg
deleted file mode 100644
index 27b9565fa669..000000000000
--- a/evewinecfg
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-EVECONF=$HOME/.config/CCP/EVE.conf
-EVEDIR=$HOME/.local/lib/EVE
-
-UCW=$(grep UseCustomWine $EVECONF | cut -d= -f2)
-if [ "x$UCW" = "xtrue" ] ;then
- WINEPATH=$(grep CustomWinePath $EVECONF | cut -d= -f2)
- WINEPATH=${WINEPATH%/*}
-else
- echo "$(basename $0): Error: Custom wine not set!"
- exit 1
-fi
-
-env WINEPREFIX=$HOME/.local/lib/EVE/SharedCache/wineenv \
- WINEDEBUG=-all \
- WINEDLLOVERRIDES="mscoree,mshtml,winemenubuilder.exe=d" \
- $WINEPATH/winecfg "$@"
diff --git a/evewinetricks b/evewinetricks
index 3cda255841c0..6a6141e67b08 100644
--- a/evewinetricks
+++ b/evewinetricks
@@ -1,15 +1,20 @@
#!/bin/sh
EVECONF=$HOME/.config/CCP/EVE.conf
-EVEDIR=$HOME/.local/lib/EVE
-
UCW=$(grep UseCustomWine $EVECONF | cut -d= -f2)
if [ "x$UCW" = "xtrue" ] ;then
- WINEPATH=$(grep CustomWinePath $EVECONF | cut -d= -f2)
+ CUSTOMWP=$(grep CustomWinePath $EVECONF | cut -d= -f2)
+ WINEPATH=${CUSTOMWP%/*}
+ SHAREDIR=$(grep SharedCacheFolder $EVECONF | cut -d= -f2)
+ WINEPREFIX=${SHAREDIR}wineenv
else
- echo "$(basename $0): Error: Custom wine not set!"
+ echo "$(basename $0): ERROR: \"Use Custom Wine\" not set!"
+ exit 1
+fi
+if [ ! -x "$WINEPATH/wine" ] ;then
+ echo "$(basename $0): ERROR: \"$CUSTOMWP\" in \"Custom Wine path\" not found!"
exit 1
fi
-env WINEPREFIX=$HOME/.local/lib/EVE/SharedCache/wineenv \
- WINE=$WINEPATH $(which winetricks) "$@"
+env WINEPREFIX=$WINEPREFIX \
+ WINE=$WINEPATH/wine $(which winetricks) "$@"
diff --git a/setup.sh.in b/setup.sh.in
index f4fb761ec26a..c08fff1eddbb 100644
--- a/setup.sh.in
+++ b/setup.sh.in
@@ -20,13 +20,24 @@ bootstrap_install() {
exit 0
fi
install -dv "${target}/bin/"
- install -d "/usr/bin/"
- install -d "/usr/share/applications/"
- for cmd in evelauncher.sh everegedit evewine evewinecfg evewinetricks ;do
- install "./$cmd" "${target}/bin/"
- ln -s "${target}/bin/$cmd" "/usr/bin/$cmd"
+ install -d "${prefix}/bin/"
+ install -d "${prefix}/share/applications/"
+ for cmd in evelauncher.sh evewine evewinetricks everegedit evewinecfg ;do
+ if [ -f "./$cmd" ] ;then
+ install "./$cmd" "${target}/bin/"
+ else
+ ln -sf evewine "${target}/bin/${cmd}"
+ fi
+ ln -s "${target}/bin/$cmd" "${prefix}/bin/$cmd"
if [ ! "$cmd" = "evewine" ] ;then
- install -m 0644 "./${cmd%.*}.desktop" "/usr/share/applications/"
+#-- testing only
+# oexec=$(grep Exec= ./${cmd%.*}.desktop)
+# sed -i s,$oexec,Exec=$prefix/bin/$cmd, ./${cmd%.*}.desktop
+#--
+ install -m 0644 "./${cmd%.*}.desktop" "${prefix}/share/applications/"
+#-- testing only
+# sed -i s,Exec=$prefix/bin/$cmd,$oexec, ./${cmd%.*}.desktop
+#--
fi
done
install -dv "${target}/lib/"
@@ -35,34 +46,36 @@ bootstrap_install() {
done
install -m 0644 "./evelauncher-${elver}.tar.gz" "${target}/lib"
for icons in $(find . -type f -name '*.png') ;do
- install -m 0644 "$icons" "/usr/share/$icons"
+ install -D -m 0644 "$icons" "${prefix}/share/${icons#*/}"
done
if [ -x $(which gtk-update-icon-cache) ] ;then
- gtk-update-icon-cache -f "/usr/share/icons/hicolor" 2>/dev/null && \
- chmod 0644 "/usr/share/icons/hicolor/icon-theme.cache"
+ gtk-update-icon-cache -t -f "${prefix}/share/icons/hicolor" 2>/dev/null
+ [ -f "${prefix}/share/icons/hicolor/icon-theme.cache" ] && \
+ chmod 0644 "${prefix}/share/icons/hicolor/icon-theme.cache"
fi
}
bootstrap_remove() {
for icons in $(find . -type f -name '*.png') ;do
- rm -f "/usr/share/$icons"
+ rm -f "${prefix}/share/${icons#*/}"
done
if [ -x $(which gtk-update-icon-cache) ] ;then
- gtk-update-icon-cache -f "/usr/share/icons/hicolor" 2>/dev/null && \
- chmod 0644 "/usr/share/icons/hicolor/icon-theme.cache"
+ gtk-update-icon-cache -t -f "${prefix}/share/icons/hicolor" 2>/dev/null
+ [ -f "${prefix}/share/icons/hicolor/icon-theme.cache" ] && \
+ chmod 0644 "${prefix}/share/icons/hicolor/icon-theme.cache"
fi
rm -rfv "${target}/lib/"
- for cmd in evelauncher.sh eveoverrides everegedit \
- evewine evewinecfg evewinetricks ;do
- rm -fv "/usr/bin/$cmd"
+ for cmd in evelauncher.sh everegedit evewine evewinecfg evewinetricks ;do
+ rm -fv "${prefix}/bin/$cmd"
if [ ! "$cmd" = "evewine" ] ;then
- rm -f "/usr/share/applications/${cmd%.*}.desktop"
+ rm -f "${prefix}/share/applications/${cmd%.*}.desktop"
fi
done
rm -rfv "${target}"
}
target="/opt/evesetup"
+prefix="/usr"
key=""
qtver="5.11"
elver="1385477"
@@ -72,17 +85,25 @@ if [ $(id -u) -ne 0 ] ;then
printf "\nExiting.\n\n"
exit 0
fi
+
if [ -d "${target}/bin/" ] ;then
printf "\n"
read -p 'Remove EVE Online Launcher Setup? (Y/n) ' key
[ ! "x$(echo $key | tr [:upper:] [:lower:])" = "xn" ] && \
bootstrap_remove
else
+#-- testing only
+# otarget=$(grep ^SETUPDIR= ./evelauncher.sh)
+# sed -i s,$otarget,SETUPDIR=\"$target\", ./evelauncher.sh
+#--
printf "\n"
read -p 'Install EVE Online Launcher Setup? (Y/n) ' key
[ ! "x$(echo $key | tr [:upper:] [:lower:])" = "xn" ] && \
bootstrap_install && \
printf "\nYou can now start EVE Online Launcher and his " && \
- echo "Tools from your Application menu."
+ echo "Tools from your Application menu."
+#-- testing only
+# sed -i s,SETUPDIR=\"$target\",$otarget, ./evelauncher.sh
+#--
fi
printf "\nDone.\n\n"