summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 20 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c65bb347af4a..3f9275434863 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,21 @@
pkgbase = exo-git
pkgdesc = Extensions to Xfce originally developed by os-cillation.
- pkgver = 0.12.11+68+ga978d108
+ pkgver = 4.19.0.r12.gb49e9eb9
pkgrel = 1
- epoch = 1
+ epoch = 2
url = https://gitlab.xfce.org/xfce/exo/
arch = i686
arch = x86_64
groups = xfce4-git
- license = GPL2
- license = LGPL2.1
- makedepends = xfce4-dev-tools
+ license = LGPL-2.1-only
makedepends = git
- makedepends = pkgconfig
- makedepends = libnotify
- makedepends = perl-uri
- depends = hicolor-icon-theme
+ makedepends = xfce4-dev-tools
depends = libxfce4ui
- optdepends = libnotify: enables notification support
- optdepends = perl: enables mail-compose helper script
- provides = exo=0.12.11+68+ga978d108
+ depends = libxfce4util
+ provides = exo=4.19.0
conflicts = exo
options = !libtool
source = exo::git+https://gitlab.xfce.org/xfce/exo.git
md5sums = SKIP
pkgname = exo-git
-
diff --git a/PKGBUILD b/PKGBUILD
index bc0b0e034e59..d947dadb9efa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Igor <f2404@yandex.ru>
+# Maintainer: Darkfish Tech <arch at darkfish dot com dot au>
+# Contributor: Igor <f2404@yandex.ru>
# Contributor: GordonGR <ntheo1979@gmail.com>
# Contributor: Pablo Lezaeta <prflr arro'a gmail puntocom> (I tryed)
# Contributor: jyantis <yantis@yantis.net>
@@ -7,35 +8,33 @@
# Contributor: Berseker <berseker86 at gmail dot com>
_pkgname=exo
-pkgname=${_pkgname}-git
-pkgver=0.12.11+68+ga978d108
+pkgname="${_pkgname}-git"
+pkgver=4.19.0.r12.gb49e9eb9
pkgrel=1
pkgdesc="Extensions to Xfce originally developed by os-cillation."
arch=('i686' 'x86_64')
-license=('GPL2' 'LGPL2.1')
+license=('LGPL-2.1-only')
url="https://gitlab.xfce.org/xfce/exo/"
groups=('xfce4-git')
-provides=("exo=${pkgver}")
-depends=('hicolor-icon-theme' 'libxfce4ui')
-makedepends=('xfce4-dev-tools' 'git' 'pkgconfig' 'libnotify' 'perl-uri')
-optdepends=('libnotify: enables notification support'
- 'perl: enables mail-compose helper script')
-conflicts=('exo')
+provides=("${_pkgname}=${pkgver%%.r*}")
+depends=('libxfce4ui' 'libxfce4util')
+makedepends=('git' 'xfce4-dev-tools')
+conflicts=("$_pkgname")
source=("${_pkgname}::git+https://gitlab.xfce.org/xfce/${_pkgname}.git")
options=('!libtool')
md5sums=('SKIP')
-epoch=1
+epoch=2
pkgver(){
cd "${_pkgname}"
- git describe --long --tags | sed -r "s:^${_pkgname}.::;s/^v//;s/^exo-//;s/-/+/g"
-# git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed "s/^${_pkgname}-//g;s/\([^-]*-g\)/r\1/;s/-/./g"
}
build() {
cd "${_pkgname}"
+ #./autogen.sh --help=recursive
./autogen.sh \
--prefix=/usr \
--sysconfdir=/etc \
@@ -43,7 +42,8 @@ build() {
--localstatedir=/var \
--disable-static \
--enable-gtk-doc \
- --disable-debug
+ --enable-debug=minimum \
+ --enable-maintainer-mode
make
}