summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD23
3 files changed, 27 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fa7caab09c8..55a2b95b4fa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,32 @@
pkgbase = foobnix-git
pkgdesc = GTK+ music player
- pkgver = 3.1.r143.88804cc7
+ pkgver = 3.2.r2.g17d5891f
pkgrel = 1
url = http://www.foobnix.com
arch = i686
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = python-setuptools
depends = python-chardet
depends = python-simplejson
depends = python-mutagen
depends = gst-plugins-good
depends = gst-plugins-base
+ depends = gst-plugins-ugly
+ depends = gst-plugins-bad
+ depends = gst-libav
depends = gst-python
depends = webkit2gtk
depends = libkeybinder3
- depends = gst-plugins-bad
- depends = gst-plugins-ugly
- depends = gst-libav
depends = fuseiso
- depends = libnotify
+ depends = python-notify2
+ depends = python3-keybinder
depends = lame
depends = faac
- depends = python3-keybinder
depends = ffmpeg
depends = python-dbus
- optdepends = python-pylast: Last.FM support
+ depends = python-pylast
provides = foobnix
conflicts = foobnix
source = git+https://github.com/foobnix/foobnix.git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index a6636a1e57b6..1f353ba913ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-# Maintainer:
+# Maintainer: Alex Tharp <toastercup at gmail dot com>
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
+_pkgname=foobnix
pkgname=foobnix-git
-pkgver=3.1.r143.88804cc7
+pkgver=3.2.r2.g17d5891f
pkgrel=1
pkgdesc="GTK+ music player"
arch=('i686' 'x86_64')
url="http://www.foobnix.com"
license=('GPL3')
-depends=('python-chardet' 'python-simplejson' 'python-mutagen' 'gst-plugins-good'
- 'gst-plugins-base' 'gst-python' 'webkit2gtk' 'libkeybinder3' 'gst-plugins-bad'
- 'gst-plugins-ugly' 'gst-libav' 'fuseiso' 'libnotify' 'lame' 'faac'
- 'python3-keybinder' 'ffmpeg' 'python-dbus')
-makedepends=('git')
-optdepends=('python-pylast: Last.FM support')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
+depends=('python-chardet' 'python-simplejson' 'python-mutagen'
+ 'gst-plugins-good' 'gst-plugins-base' 'gst-plugins-ugly'
+ 'gst-plugins-bad' 'gst-libav' 'gst-python' 'webkit2gtk'
+ 'libkeybinder3' 'fuseiso' 'python-notify2' 'python3-keybinder'
+ 'lame' 'faac' 'ffmpeg' 'python-dbus' 'python-pylast')
+makedepends=('git' 'python-setuptools')
+provides=("foobnix")
+conflicts=("foobnix")
source=('git+https://github.com/foobnix/foobnix.git')
sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {