summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6636a1e57b6..1f353ba913ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-# Maintainer:
+# Maintainer: Alex Tharp <toastercup at gmail dot com>
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
+_pkgname=foobnix
pkgname=foobnix-git
-pkgver=3.1.r143.88804cc7
+pkgver=3.2.r2.g17d5891f
pkgrel=1
pkgdesc="GTK+ music player"
arch=('i686' 'x86_64')
url="http://www.foobnix.com"
license=('GPL3')
-depends=('python-chardet' 'python-simplejson' 'python-mutagen' 'gst-plugins-good'
- 'gst-plugins-base' 'gst-python' 'webkit2gtk' 'libkeybinder3' 'gst-plugins-bad'
- 'gst-plugins-ugly' 'gst-libav' 'fuseiso' 'libnotify' 'lame' 'faac'
- 'python3-keybinder' 'ffmpeg' 'python-dbus')
-makedepends=('git')
-optdepends=('python-pylast: Last.FM support')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
+depends=('python-chardet' 'python-simplejson' 'python-mutagen'
+ 'gst-plugins-good' 'gst-plugins-base' 'gst-plugins-ugly'
+ 'gst-plugins-bad' 'gst-libav' 'gst-python' 'webkit2gtk'
+ 'libkeybinder3' 'fuseiso' 'python-notify2' 'python3-keybinder'
+ 'lame' 'faac' 'ffmpeg' 'python-dbus' 'python-pylast')
+makedepends=('git' 'python-setuptools')
+provides=("foobnix")
+conflicts=("foobnix")
source=('git+https://github.com/foobnix/foobnix.git')
sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {