summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdffa98d2bfa..546d1bbb9762 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by mksrcinfo v8
-# Sat Apr 21 15:07:24 UTC 2018
pkgbase = getdata
pkgdesc = reference implementation of the Dirfile Standards
- pkgver = 0.10.0
+ pkgver = 0.11.0
pkgrel = 1
url = http://getdata.sourceforge.net/
arch = i686
arch = x86_64
license = GPL
- source = http://downloads.sourceforge.net/project/getdata/getdata/0.10.0/getdata-0.10.0.tar.gz
- md5sums = bc7150fd2cdff314d3c0b318ffc1f572
+ depends = pcre2
+ source = https://github.com/ketiltrout/getdata/releases/download/v0.11.0/getdata-0.11.0.tar.gz
+ b2sums = bff794686ece671536a240f235fff4d4cc94d8faea63192d535231c86f630b5a254738fef18dd54159dd1508a2ff07a010d12ca49754cb3d8efcc4ea91de2fb2
pkgname = getdata
-
diff --git a/PKGBUILD b/PKGBUILD
index e558bef9d54a..863d7d8a8d89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
# Contributor: Maximilian Stein <theoddbird@posteo.org>
pkgname=getdata
-pkgver=0.10.0
+pkgver=0.11.0
pkgrel=1
pkgdesc="reference implementation of the Dirfile Standards"
arch=('i686' 'x86_64')
url="http://getdata.sourceforge.net/"
license=('GPL')
-source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('bc7150fd2cdff314d3c0b318ffc1f572')
+depends=(pcre2) #python
+source=(https://github.com/ketiltrout/getdata/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
+b2sums=('bff794686ece671536a240f235fff4d4cc94d8faea63192d535231c86f630b5a254738fef18dd54159dd1508a2ff07a010d12ca49754cb3d8efcc4ea91de2fb2')
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --disable-matlab --with-python="/usr/bin/python2"
- #CC="/usr/bin/gcc-5"
+ cd "$pkgname-$pkgver"
+ #./configure --prefix=/usr --disable-matlab --with-python="/usr/bin/python" --with-pcre
+ ./configure --prefix=/usr --disable-matlab --without-python --with-pcre
+ make
}
+
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
make DESTDIR=$pkgdir install
}