summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e558bef9d54a..863d7d8a8d89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
# Contributor: Maximilian Stein <theoddbird@posteo.org>
pkgname=getdata
-pkgver=0.10.0
+pkgver=0.11.0
pkgrel=1
pkgdesc="reference implementation of the Dirfile Standards"
arch=('i686' 'x86_64')
url="http://getdata.sourceforge.net/"
license=('GPL')
-source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('bc7150fd2cdff314d3c0b318ffc1f572')
+depends=(pcre2) #python
+source=(https://github.com/ketiltrout/getdata/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
+b2sums=('bff794686ece671536a240f235fff4d4cc94d8faea63192d535231c86f630b5a254738fef18dd54159dd1508a2ff07a010d12ca49754cb3d8efcc4ea91de2fb2')
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --disable-matlab --with-python="/usr/bin/python2"
- #CC="/usr/bin/gcc-5"
+ cd "$pkgname-$pkgver"
+ #./configure --prefix=/usr --disable-matlab --with-python="/usr/bin/python" --with-pcre
+ ./configure --prefix=/usr --disable-matlab --without-python --with-pcre
+ make
}
+
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
make DESTDIR=$pkgdir install
}