summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cdae4cc15b9..cc5900db6e28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ghdl-gcc-git
pkgdesc = VHDL simulator - GCC back-end
- pkgver = 3.0.0dev.r7048.g7028d03e5
+ pkgver = 5.0.0dev.r9326.gec7cd5909
pkgrel = 1
url = https://github.com/ghdl/ghdl
install = ghdl.install
@@ -14,13 +14,14 @@ pkgbase = ghdl-gcc-git
license = GPL2
makedepends = git
depends = gcc-ada
- provides = ghdl=3.0.0dev.r7048.g7028d03e5
- provides = ghdl-git=3.0.0dev.r7048.g7028d03e5
+ provides = ghdl=5.0.0dev.r9326.gec7cd5909
+ provides = ghdl-git=5.0.0dev.r9326.gec7cd5909
conflicts = ghdl
conflicts = ghdl-llvm-git
conflicts = ghdl-mcode-git
options = !emptydirs
options = staticlibs
+ options = !lto
source = ghdl::git+https://github.com/ghdl/ghdl.git
source = https://gcc.gnu.org/pub/gcc/releases/gcc-11.2.0/gcc-11.2.0.tar.xz
source = https://gcc.gnu.org/pub/gcc/infrastructure/isl-0.24.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
index a135430a07fd..d6c5203515e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrien Prost-Boucle <adrien.prost-boucle@laposte.net>
pkgname=ghdl-gcc-git
-pkgver=3.0.0dev.r7048.g7028d03e5
+pkgver=5.0.0dev.r9326.gec7cd5909
pkgrel=1
arch=('x86_64' 'i686' 'pentium4' 'arm' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='VHDL simulator - GCC back-end'
@@ -13,7 +13,7 @@ conflicts=('ghdl' 'ghdl-llvm-git' 'ghdl-mcode-git')
makedepends=('git')
depends=('gcc-ada')
install=ghdl.install
-options=(!emptydirs staticlibs)
+options=(!emptydirs staticlibs !lto)
_gccver=11.2.0
_islver=0.24
@@ -23,11 +23,9 @@ source=(
"https://gcc.gnu.org/pub/gcc/releases/gcc-${_gccver}/gcc-${_gccver}.tar.xz"
"https://gcc.gnu.org/pub/gcc/infrastructure/isl-${_islver}.tar.bz2"
)
-sha256sums=(
- 'SKIP'
- 'd08edc536b54c372a1010ff6619dd274c0f1603aa49212ba20f7aa2cda36fa8b'
- 'fcf78dd9656c10eb8cf9fbd5f59a0b6b01386205fe1934b3b287a0a1898145c0'
-)
+sha256sums=('SKIP'
+ 'd08edc536b54c372a1010ff6619dd274c0f1603aa49212ba20f7aa2cda36fa8b'
+ 'fcf78dd9656c10eb8cf9fbd5f59a0b6b01386205fe1934b3b287a0a1898145c0')
pkgver() {
cd "${srcdir}/ghdl"