summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD76
-rw-r--r--gamespath.patch11
4 files changed, 66 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8dc115b70c23..cc7935752996 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = ialauncher-git
- pkgdesc = Play all of the Internet Archive’s MS-DOS games offline!
- pkgver = 1
+ pkgdesc = Play all of the Internet Archive’s MS-DOS games offline
+ pkgver = r127.b93f75d
pkgrel = 1
url = https://github.com/rtts/ialauncher
- arch = x86_64
+ arch = any
license = GPL3
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = dosbox
- depends = webkit2gtk
- depends = python
- depends = python-natsort
- depends = gst-plugins-bad
- source = ialauncher::git+https://github.com/rtts/ialauncher.git
- source = gamespath.patch
+ depends = python-pygame
+ depends = python-pyxdg
+ options = !strip
+ source = ialauncher::git+https://github.com/rtts/ialauncher
+ source = ialauncher-19-xdg-cache.patch::https://github.com/rtts/ialauncher/pull/19.patch
sha256sums = SKIP
- sha256sums = 3d1fc7b7ad96bcbeb2f3a8331df7c157c9720c4f3c685715cba0aa1a98a2c166
+ sha256sums = 6def4ff58722dc5efbbd93c19837bb80774bb2d979a69567279273a4e0a4dc5b
pkgname = ialauncher-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index d46e7777894f..5ec930922f3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,61 @@
-# Maintainer: gee
+# Maintainer:
+# Contributor: gee
-pkgname=ialauncher-git
-pkgver=1
+_pkgname="ialauncher"
+pkgname="$_pkgname-git"
+pkgver=r127.b93f75d
pkgrel=1
-pkgdesc='Play all of the Internet Archive’s MS-DOS games offline!'
-arch=('x86_64')
+pkgdesc='Play all of the Internet Archive’s MS-DOS games offline'
+arch=('any')
url='https://github.com/rtts/ialauncher'
license=('GPL3')
-depends=('dosbox' 'webkit2gtk' 'python' 'python-natsort' 'gst-plugins-bad')
-source=('ialauncher::git+https://github.com/rtts/ialauncher.git'
- 'gamespath.patch')
-sha256sums=('SKIP'
- '3d1fc7b7ad96bcbeb2f3a8331df7c157c9720c4f3c685715cba0aa1a98a2c166')
-# no tags yet
-#pkgver() {
-# cd ialauncher
-
-# git describe | sed 's/-/.r/; s/-g/./'
-#}
-
-#prepare() {
-# cd ialauncher
+depends=(
+ 'dosbox'
+ 'python-pygame'
+ 'python-pyxdg'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
+
+options=(!strip)
+
+source=(
+ "$_pkgname"::"git+$url"
+ "ialauncher-19-xdg-cache.patch"::"https://github.com/rtts/ialauncher/pull/19.patch"
+)
+sha256sums=(
+ 'SKIP'
+ '6def4ff58722dc5efbbd93c19837bb80774bb2d979a69567279273a4e0a4dc5b'
+)
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ for patch in "$srcdir"/*.patch ; do
+ if [ -f "$patch" ] ; then
+ echo "Applying patch: ${patch##*/}"
+ patch -Np1 -F100 -i "$patch"
+ fi
+ done
+}
-# patch -Np1 -i "${srcdir}/gamespath.patch"
-#}
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
- cd ialauncher
-
- python setup.py build
+ cd "$srcdir/$_pkgname"
+ python -m build --no-isolation --wheel
}
package() {
cd ialauncher
-
- python setup.py install --root="$pkgdir"
- #install -dm 755 "${pkgdir}/opt/ialauncher/"
- #cp -r games "${pkgdir}/opt/ialauncher/"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
diff --git a/gamespath.patch b/gamespath.patch
deleted file mode 100644
index 2f4762e7d7d6..000000000000
--- a/gamespath.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/bin/ialauncher
-+++ b/bin/ialauncher
-@@ -4,7 +4,7 @@
- from ialauncher.backend import Backend
- from ialauncher.frontend import Frontend
-
--games_dir= os.path.join(os.path.expanduser("~"), 'games')
-+games_dir= '/opt/ialauncher/games'
- if not os.path.isdir(games_dir):
- print('''
- Error: the games directory could not be found at {}