summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rwxr-xr-xPKGBUILD35
2 files changed, 30 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d849700300bd..ae479bda751c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = icytower
pkgdesc = Harold the Homeboy and his friends have decided to climb a huge tower they found the other day. It's up to you to help them get as high as possible without falling down, and collect extra points by doing cool moves on the way.
- pkgver = 1.0.1
+ pkgver = 1.0.2
pkgrel = 1
+ url = https://gitlab.com/linuxbombay/icytower
arch = pentium4
arch = x86_64
license = GPL
@@ -11,7 +12,7 @@ pkgbase = icytower
depends = lib32-libpulse
depends = unzip
depends = yad
- source = https://gitlab.com/icytower/icytower/-/archive/1.0.1-1/icytower-1.0.1-1.tar.gz
- sha256sums = SKIP
+ source = https://gitlab.com/linuxbombay/icytower/icytower/-/archive/1.0.2-1/icytower-1.0.2-1.tar.bz2
+ sha256sums = b9a900c533acf3c937115675cb16b044e71438f46f069e91087d93fd5ebfc275
pkgname = icytower
diff --git a/PKGBUILD b/PKGBUILD
index 482a22967ae7..1cb6782be7e0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,39 @@
pkgname=icytower
_pkgname=IcyTower
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
pkgdesc="Harold the Homeboy and his friends have decided to climb a huge tower they found the other day. It's up to you to help them get as high as possible without falling down, and collect extra points by doing cool moves on the way."
arch=('pentium4' 'x86_64')
-url=""
+url="https://gitlab.com/linuxbombay/icytower"
license=('GPL')
depends=('wget' 'wine' 'lib32-libpulse' 'unzip' 'yad')
makedepends=('unzip')
-source=("https://gitlab.com/icytower/icytower/-/archive/$pkgver-$pkgrel/icytower-$pkgver-$pkgrel.tar.gz")
-sha256sums=("SKIP")
-
+source=("$url/icytower/-/archive/$pkgver-$pkgrel/icytower-$pkgver-$pkgrel.tar.bz2")
+sha256sums=('b9a900c533acf3c937115675cb16b044e71438f46f069e91087d93fd5ebfc275')
package() {
- install -dm755 "$pkgdir/usr/share/games/$_pkgname"
- install -dm755 "$pkgdir/usr/bin"
- install -dm755 "$pkgdir/usr/share/pixmaps"
+ install -d -m755 "$pkgdir/usr/share/games/$_pkgname"
+ install -d -m755 "$pkgdir/usr/bin"
+ install -d -m755 "$pkgdir/usr/share/pixmaps"
+ # Check if the source directory exists
+DIR="/usr/share/games/IcyTower"
+if [ -d "$DIR" ]; then
+ echo "Source directory exists."
+ # Copy all files from the source directory to the destination directory
+ cp -r "$DIR"/* "$pkgdir/usr/share/games/$_pkgname"
+ echo "Files copied successfully."
+else
+ cd "$srcdir"
+ # Deleting any existing downloads
+ rm -rf "IcyTower.tar.gz"
+ wget "$url/Binaries/1.3.1/-/raw/main/IcyTower.tar.gz"
+ tar -xf IcyTower.tar.gz -C "$pkgdir/usr/share/games/$_pkgname"
+ if [ $? -ne 0 ]; then
+ echo "Download failed"
+ exit 1
+ fi
+fi
cd "$srcdir/icytower-$pkgver-$pkgrel"
- wget "https://gitlab.com/icytower/Binaries/1.3.1/-/raw/main/IcyTower.tar.gz"
cp -r ./ "$pkgdir/usr/share/games/$_pkgname"
cp -r "$pkgdir/usr/share/games/$_pkgname/$pkgname.png" "$pkgdir/usr/share/pixmaps"
@@ -29,3 +45,4 @@ package() {
"$pkgdir/usr/share/applications/$_pkgname.desktop"
sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/$_pkgname.desktop"
}
+