summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch35
-rw-r--r--PKGBUILD20
3 files changed, 56 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f5cbf46507d..b194b96a18b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = idevicerestore-git
pkgdesc = Restore/upgrade firmware of iOS devices
- pkgver = r663.0b4810f
+ pkgver = 1.0.0.r134.g163a164
pkgrel = 1
epoch = 1
url = http://www.libimobiledevice.org
@@ -8,15 +8,18 @@ pkgbase = idevicerestore-git
arch = x86_64
license = LGPL3
makedepends = git
- depends = libirecovery-git
- depends = libimobiledevice
depends = libzip
depends = openssl
depends = curl
+ depends = libimobiledevice-glue-git
+ depends = libplist-git
+ depends = libimobiledevice-git
+ depends = libirecovery-git
source = git+https://github.com/libimobiledevice/idevicerestore
source = 0001-configure.ac-check-for-pthreads.patch
+ source = 0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch
sha256sums = SKIP
sha256sums = d7fcc4e46a175d309298bd95d330c027fcca7dba3226f3e1b802c8ebe8d8ed15
+ sha256sums = b1348ccc86d0ccbbc5bf6fa4e2027b0303a52673431ace50cc1e0ef8a6171305
pkgname = idevicerestore-git
-
diff --git a/0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch b/0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch
new file mode 100644
index 000000000000..4465c4b02741
--- /dev/null
+++ b/0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch
@@ -0,0 +1,35 @@
+From 3d389b0735cf2b46a1c747e3fe9f09a5410e7eaf Mon Sep 17 00:00:00 2001
+From: Ivan Shapovalov <intelfx@intelfx.name>
+Date: Fri, 5 May 2023 18:42:52 +0300
+Subject: [PATCH 2/2] configure.ac: accept unreleased libirecovery-1.0 =
+ 1.0.0-<n>
+
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 74782f5..d97959d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,7 +15,7 @@ if test -z $PACKAGE_VERSION; then
+ fi
+
+ # Minimum package versions
+-LIBIRECOVERY_VERSION=1.0.1
++LIBIRECOVERY_VERSION=1.0.0
+ LIBIMOBILEDEVICE_VERSION=1.3.0
+ LIBPLIST_VERSION=2.3.0
+ LIMD_GLUE_VERSION=1.0.0
+@@ -38,7 +38,7 @@ LT_INIT
+
+ # Checks for libraries.
+ AC_SEARCH_LIBS([pthread_create], [pthread])
+-PKG_CHECK_MODULES(libirecovery, libirecovery-1.0 >= $LIBIRECOVERY_VERSION)
++PKG_CHECK_MODULES(libirecovery, libirecovery-1.0 > $LIBIRECOVERY_VERSION)
+ PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= $LIBIMOBILEDEVICE_VERSION)
+ PKG_CHECK_MODULES(libplist, libplist-2.0 >= $LIBPLIST_VERSION)
+ PKG_CHECK_MODULES(limd_glue, libimobiledevice-glue-1.0 >= $LIMD_GLUE_VERSION)
+--
+2.40.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 4ee251ed1cce..ece00cd772c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,24 @@
pkgname=idevicerestore-git
epoch=1
-pkgver=r705.21a242e
+pkgver=1.0.0.r134.g163a164
pkgrel=1
pkgdesc="Restore/upgrade firmware of iOS devices"
arch=('i686' 'x86_64')
url="http://www.libimobiledevice.org"
license=('LGPL3')
-depends=('libirecovery-git' 'libimobiledevice' 'libzip' 'openssl' 'curl')
+depends=('libzip' 'openssl' 'curl' 'libimobiledevice-glue-git' 'libplist-git' 'libimobiledevice-git' 'libirecovery-git')
makedepends=('git')
source=("git+https://github.com/libimobiledevice/idevicerestore"
- "0001-configure.ac-check-for-pthreads.patch")
+ '0001-configure.ac-check-for-pthreads.patch'
+ '0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch')
sha256sums=('SKIP'
- 'd7fcc4e46a175d309298bd95d330c027fcca7dba3226f3e1b802c8ebe8d8ed15')
+ 'd7fcc4e46a175d309298bd95d330c027fcca7dba3226f3e1b802c8ebe8d8ed15'
+ 'b1348ccc86d0ccbbc5bf6fa4e2027b0303a52673431ace50cc1e0ef8a6171305')
pkgver() {
cd idevicerestore
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/[^-]*-g/r&/;s/-/./g'
}
prepare() {
@@ -31,10 +33,16 @@ prepare() {
build() {
cd idevicerestore
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ #sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool # not needed anymore (libtool honors $LDFLAGS now)
make
}
+check() {
+ cd idevicerestore
+ make check
+}
+
package() {
cd idevicerestore
make DESTDIR="$pkgdir" install