summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21e7c995330a..2752e9e93537 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,10 +9,9 @@ pkgbase = libhashab-git
license = GPL
makedepends = git
depends = libgpod
- source = git://github.com/neheb/libhashab.git
+ source = git+https://github.com/neheb/libhashab.git
source = lib.patch
md5sums = SKIP
md5sums = 7d5be1e8b685cd1e1c645da5c7c2ffe4
pkgname = libhashab-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4748ef51b347..249d5d92ade5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url="https://github.com/neheb/libhashab"
license=("unknown" "GPL")
depends=("libgpod")
makedepends=("git")
-source=("git://github.com/neheb/libhashab.git"
+source=("git+https://github.com/neheb/libhashab.git"
"lib.patch")
md5sums=("SKIP"
"7d5be1e8b685cd1e1c645da5c7c2ffe4")
@@ -27,7 +27,7 @@ build() {
package() {
cd $_pkgname
- install -D -m777 "src/libhashab.so" "${pkgdir}/usr/lib/libgpod/libhashab.so"
+ install -D -m777 "libhashab64_original.so" "${pkgdir}/usr/lib/libgpod/libhashab.so"
install -D -m777 "src/libhashab32_wrapper" "${pkgdir}/usr/lib/libgpod/libhashab32_wrapper"
install -D -m777 "libhashab32.so" "${pkgdir}/usr/lib/libgpod/libhashab32.so"
}