summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
-rw-r--r--lightscreen.desktop9
-rw-r--r--screenshot_cpp_h_fix.patch75
4 files changed, 10 insertions, 105 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6ed9755e8ac..6cc504efc3fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Wed Dec 21 19:29:33 UTC 2016
pkgbase = lightscreen
pkgdesc = Simple tool to automate the tedious process of saving and cataloging screenshots
- pkgver = 2.4
- pkgrel = 5
+ pkgver = 2.5
+ pkgrel = 6
url = http://lightscreen.com.ar/
arch = i686
arch = x86_64
@@ -13,14 +11,11 @@ pkgbase = lightscreen
depends = qt5-xmlpatterns
depends = qt5-multimedia
depends = qt5-x11extras
- source = lightscreen-2.4.tar.gz::https://github.com/ckaiser/Lightscreen/archive/v2.4.tar.gz
+ source = lightscreen-2.5.tar.gz::https://github.com/ckaiser/Lightscreen/archive/v2.5.tar.gz
source = UGlobalHotkey-231b10.zip::https://github.com/ckaiser/UGlobalHotkey/archive/231b10144741b29037f0128bb7a1cd7176529f74.zip
source = SingleApplication-c6378e.zip::https://github.com/ckaiser/SingleApplication/archive/c6378eec45a5fdf699b4d27fb4be22a190b2a184.zip
- source = screenshot_cpp_h_fix.patch
- sha512sums = 4a16eb4e6a610809cb5d74e60779f708ad924bac8cceb71d60294034144b58997d772828a64e51c73351ba31f3a4d1dd65ea563f59c59172c66b0ee70f03f18d
+ sha512sums = 51243612ecf2fa9105a321aa09af6f2b2422e320f0eb9b6a30a9db84f7d2494f064d281e1a6e8f1f98f401e4991d25215582db769d8449a6582ab731cd9af099
sha512sums = 444486f71c6cee80fc2b7bbd0b75335c1eefc8b8c949fb83438d2761c28c89fb345ad99b0195f8726c03984e30c46bf4788168927c28725beb3b31d0349e0778
sha512sums = ca3ab82c9a98180218afb0936b87b8f156def8ef4d84926930c81ef3c12ae66807d4f27b403bd01b6c8b1def5507ac9b47017b38c44ce7e5dd3119bc0dcce17b
- sha512sums = 67193adc30beee7e9fdb72bbcc5d06960ac2b4f7125f7924c9f4d43ea4459d8bf3a79db3f4f4fc2e0a888a298744a13030e1bc708b2693238aa9691ff7ee7e5f
pkgname = lightscreen
-
diff --git a/PKGBUILD b/PKGBUILD
index ffce5e45c09a..d5cdf784ce0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Chris <christopher.r.mullins g-mail>
pkgname=lightscreen
-pkgver=2.4
-pkgrel=5
+pkgver=2.5
+pkgrel=6
pkgdesc='Simple tool to automate the tedious process of saving and cataloging screenshots'
arch=('i686' 'x86_64')
url='http://lightscreen.com.ar/'
@@ -14,19 +14,13 @@ depends=('qt5-base'
license=('GPL')
source=("lightscreen-$pkgver.tar.gz::https://github.com/ckaiser/Lightscreen/archive/v$pkgver.tar.gz"
"UGlobalHotkey-231b10.zip::https://github.com/ckaiser/UGlobalHotkey/archive/231b10144741b29037f0128bb7a1cd7176529f74.zip"
- "SingleApplication-c6378e.zip::https://github.com/ckaiser/SingleApplication/archive/c6378eec45a5fdf699b4d27fb4be22a190b2a184.zip"
- "screenshot_cpp_h_fix.patch"
- "lightscreen.desktop")
-
-sha512sums=('4a16eb4e6a610809cb5d74e60779f708ad924bac8cceb71d60294034144b58997d772828a64e51c73351ba31f3a4d1dd65ea563f59c59172c66b0ee70f03f18d'
+ "SingleApplication-c6378e.zip::https://github.com/ckaiser/SingleApplication/archive/c6378eec45a5fdf699b4d27fb4be22a190b2a184.zip")
+sha512sums=('51243612ecf2fa9105a321aa09af6f2b2422e320f0eb9b6a30a9db84f7d2494f064d281e1a6e8f1f98f401e4991d25215582db769d8449a6582ab731cd9af099'
'444486f71c6cee80fc2b7bbd0b75335c1eefc8b8c949fb83438d2761c28c89fb345ad99b0195f8726c03984e30c46bf4788168927c28725beb3b31d0349e0778'
- 'ca3ab82c9a98180218afb0936b87b8f156def8ef4d84926930c81ef3c12ae66807d4f27b403bd01b6c8b1def5507ac9b47017b38c44ce7e5dd3119bc0dcce17b'
- '67193adc30beee7e9fdb72bbcc5d06960ac2b4f7125f7924c9f4d43ea4459d8bf3a79db3f4f4fc2e0a888a298744a13030e1bc708b2693238aa9691ff7ee7e5f'
- '24ca094e300ab0733dd7de5e24383ab3e78f775a00e441363c1bfd49323f49564d9b71b914462213b9c936c6fd19093ae454aeb4992fa5466cded379cc3e5fc3')
+ 'ca3ab82c9a98180218afb0936b87b8f156def8ef4d84926930c81ef3c12ae66807d4f27b403bd01b6c8b1def5507ac9b47017b38c44ce7e5dd3119bc0dcce17b')
+
prepare() {
- cd "${srcdir}"/"Lightscreen-${pkgver}"
- patch -Np0 -i ../screenshot_cpp_h_fix.patch
cd "${srcdir}"
cp UGlobalHotkey-231b10144741b29037f0128bb7a1cd7176529f74/* "${srcdir}"/"Lightscreen-${pkgver}/tools/UGlobalHotkey"
cp SingleApplication-c6378eec45a5fdf699b4d27fb4be22a190b2a184/* "${srcdir}"/"Lightscreen-${pkgver}/tools/SingleApplication"
diff --git a/lightscreen.desktop b/lightscreen.desktop
deleted file mode 100644
index 82c5ff9627d7..000000000000
--- a/lightscreen.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=Lightscreen
-Comment=The easy screenshot tool.
-Exec=lightscreen
-Icon=/path/to/lightscreen/src/Lightscreen-2.4/images/LS.ico
-Categories=Graphics
-Terminal=false
-Type=Application
-Version=2.4
diff --git a/screenshot_cpp_h_fix.patch b/screenshot_cpp_h_fix.patch
deleted file mode 100644
index cb33cf34f7d4..000000000000
--- a/screenshot_cpp_h_fix.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-diff -Naurp src-orig/Lightscreen-2.3/lightscreenwindow.cpp src-fixed/Lightscreen-2.3/lightscreenwindow.cpp
---- lightscreenwindow.cpp 2016-10-30 17:52:35.000000000 -0400
-+++ lightscreenwindow.cpp 2016-11-21 18:16:57.486217211 -0500
-@@ -206,7 +206,7 @@ void LightscreenWindow::cleanup(Screensh
- }
-
- if (settings()->value("options/playSound", false).toBool()) {
-- if (options.result == Screenshot::Success) {
-+ if (options.result == Screenshot::Success_) {
- QSound::play("sounds/ls.screenshot.wav");
- } else {
- #ifdef Q_OS_WIN
-@@ -220,7 +220,7 @@ void LightscreenWindow::cleanup(Screensh
-
- updateStatus();
-
-- if (options.result != Screenshot::Success) {
-+ if (options.result != Screenshot::Success_) {
- return;
- }
-
-@@ -377,7 +377,7 @@ void LightscreenWindow::executeArguments
- void LightscreenWindow::notify(const Screenshot::Result &result)
- {
- switch (result) {
-- case Screenshot::Success:
-+ case Screenshot::Success_:
- mTrayIcon->setIcon(QIcon(":/icons/lightscreen.yes"));
-
- if (mHasTaskbarButton) {
-@@ -645,7 +645,7 @@ void LightscreenWindow::showScreenshotMe
- QString title;
- QString message;
-
-- if (result == Screenshot::Success) {
-+ if (result == Screenshot::Success_) {
- title = QFileInfo(fileName).fileName();
-
- if (settings()->value("file/target").toString().isEmpty()) {
-diff -Naurp src-orig/Lightscreen-2.3/tools/screenshot.cpp src-fixed/Lightscreen-2.3/tools/screenshot.cpp
---- tools/screenshot.cpp 2016-10-30 17:52:35.000000000 -0400
-+++ tools/screenshot.cpp 2016-11-21 18:16:40.246217313 -0500
-@@ -244,7 +244,7 @@ void Screenshot::save()
- QApplication::clipboard()->setPixmap(mPixmap, QClipboard::Clipboard);
-
- if (!mOptions.file) {
-- result = Screenshot::Success;
-+ result = Screenshot::Success_;
- }
- }
-
-@@ -254,9 +254,9 @@ void Screenshot::save()
- if (name.isEmpty()) {
- result = Screenshot::Cancel;
- } else if (mUnloaded) {
-- result = (QFile::rename(mUnloadFilename, fileName)) ? Screenshot::Success : Screenshot::Failure;
-+ result = (QFile::rename(mUnloadFilename, fileName)) ? Screenshot::Success_ : Screenshot::Failure;
- } else if (mPixmap.save(fileName, 0, mOptions.quality)) {
-- result = Screenshot::Success;
-+ result = Screenshot::Success_;
- } else {
- result = Screenshot::Failure;
- }
-diff -Naurp src-orig/Lightscreen-2.3/tools/screenshot.h src-fixed/Lightscreen-2.3/tools/screenshot.h
---- tools/screenshot.h 2016-10-30 17:52:35.000000000 -0400
-+++ tools/screenshot.h 2016-11-21 18:16:31.439550699 -0500
-@@ -55,7 +55,7 @@ public:
-
- enum Result {
- Failure = 0,
-- Success = 1,
-+ Success_ = 1,
- Cancel = 2
- };
- Q_ENUM(Result)