summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffce5e45c09a..d5cdf784ce0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Chris <christopher.r.mullins g-mail>
pkgname=lightscreen
-pkgver=2.4
-pkgrel=5
+pkgver=2.5
+pkgrel=6
pkgdesc='Simple tool to automate the tedious process of saving and cataloging screenshots'
arch=('i686' 'x86_64')
url='http://lightscreen.com.ar/'
@@ -14,19 +14,13 @@ depends=('qt5-base'
license=('GPL')
source=("lightscreen-$pkgver.tar.gz::https://github.com/ckaiser/Lightscreen/archive/v$pkgver.tar.gz"
"UGlobalHotkey-231b10.zip::https://github.com/ckaiser/UGlobalHotkey/archive/231b10144741b29037f0128bb7a1cd7176529f74.zip"
- "SingleApplication-c6378e.zip::https://github.com/ckaiser/SingleApplication/archive/c6378eec45a5fdf699b4d27fb4be22a190b2a184.zip"
- "screenshot_cpp_h_fix.patch"
- "lightscreen.desktop")
-
-sha512sums=('4a16eb4e6a610809cb5d74e60779f708ad924bac8cceb71d60294034144b58997d772828a64e51c73351ba31f3a4d1dd65ea563f59c59172c66b0ee70f03f18d'
+ "SingleApplication-c6378e.zip::https://github.com/ckaiser/SingleApplication/archive/c6378eec45a5fdf699b4d27fb4be22a190b2a184.zip")
+sha512sums=('51243612ecf2fa9105a321aa09af6f2b2422e320f0eb9b6a30a9db84f7d2494f064d281e1a6e8f1f98f401e4991d25215582db769d8449a6582ab731cd9af099'
'444486f71c6cee80fc2b7bbd0b75335c1eefc8b8c949fb83438d2761c28c89fb345ad99b0195f8726c03984e30c46bf4788168927c28725beb3b31d0349e0778'
- 'ca3ab82c9a98180218afb0936b87b8f156def8ef4d84926930c81ef3c12ae66807d4f27b403bd01b6c8b1def5507ac9b47017b38c44ce7e5dd3119bc0dcce17b'
- '67193adc30beee7e9fdb72bbcc5d06960ac2b4f7125f7924c9f4d43ea4459d8bf3a79db3f4f4fc2e0a888a298744a13030e1bc708b2693238aa9691ff7ee7e5f'
- '24ca094e300ab0733dd7de5e24383ab3e78f775a00e441363c1bfd49323f49564d9b71b914462213b9c936c6fd19093ae454aeb4992fa5466cded379cc3e5fc3')
+ 'ca3ab82c9a98180218afb0936b87b8f156def8ef4d84926930c81ef3c12ae66807d4f27b403bd01b6c8b1def5507ac9b47017b38c44ce7e5dd3119bc0dcce17b')
+
prepare() {
- cd "${srcdir}"/"Lightscreen-${pkgver}"
- patch -Np0 -i ../screenshot_cpp_h_fix.patch
cd "${srcdir}"
cp UGlobalHotkey-231b10144741b29037f0128bb7a1cd7176529f74/* "${srcdir}"/"Lightscreen-${pkgver}/tools/UGlobalHotkey"
cp SingleApplication-c6378eec45a5fdf699b4d27fb4be22a190b2a184/* "${srcdir}"/"Lightscreen-${pkgver}/tools/SingleApplication"