summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch20
-rw-r--r--0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch125
-rw-r--r--0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch42
-rw-r--r--0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch242
-rw-r--r--PKGBUILD16
6 files changed, 394 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3faecb57388..c2f0939c0d3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-uksm
pkgver = 4.16.12
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dolohow/uksm
arch = x86_64
license = GPL2
@@ -19,7 +19,8 @@ pkgbase = linux-uksm
source = 99-linux.hook
source = linux.preset
source = 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- source = 0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ source = 0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch
+ source = 0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha512sums = ab47849314b177d0eec9dbf261f33972b0d89fb92fb0650130ffa7abc2f36c0fab2d06317dc1683c51a472a9a631573a9b1e7258d6281a2ee189897827f14662
@@ -35,8 +36,9 @@ pkgbase = linux-uksm
sha512sums = 4a8b324aee4cccf3a512ad04ce1a272d14e5b05c8de90feb82075f55ea3845948d817e1b0c6f298f5816834ddd3e5ce0a0e2619866289f3c1ab8fd2f35f04f44
sha512sums = 6346b66f54652256571ef65da8e46db49a95ac5978ecd57a507c6b2a28aee70bb3ff87045ac493f54257c9965da1046a28b72cb5abb0087204d257f14b91fd74
sha512sums = 2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf
- sha512sums = 99c4b03829317b03839c4bcf8a5ffead5918504b95b4bf2733ca38ec5a153a03781aa4b5e6f4297cc12c1e63a07a74da04b730f107ede212fe247e658933853b
- sha512sums = 7621840ad2f9760b30885b46b1b4e5b2b51d726a7ee771ce7649fb217c3af16577edb65c326b0754cf1a87b00fb981f0697ce916b3dcaf80731bc9a373aa685c
+ sha512sums = 26619b938a47c841f0c480a113cfbb1ee6f1121c21dfecbe246c1f7af7697f86cfb8253f09966eab2e386734ce4ad156159babdba4365c2f199c369c3d7e8ee8
+ sha512sums = f6aed92697c35e7919a0d784185e7af15b6be2762e3dd235267ca9744a826ac693d0ffcb07b9d1cc8571f57d518c1ce1c276cf7677e8375188f05f71d4added0
+ sha512sums = cc8852b089aa24f588ad1af726503ecd1012ad7e1cbc47ea77f03a5f7aecd25306d40f2e16b8a1afeafe7e2e97b6b6840c9f462ed7be358090117e2e024df1bd
pkgname = linux-uksm
pkgdesc = Linux Kernel and modules with the UKSM.
diff --git a/0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch b/0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
index 724b168dc89b..3dd9a7d7039e 100644
--- a/0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+++ b/0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
@@ -1,8 +1,8 @@
-From 44c5097b2711429f0d49d138681f67157982e729 Mon Sep 17 00:00:00 2001
-Message-Id: <44c5097b2711429f0d49d138681f67157982e729.1518653356.git.jan.steffens@gmail.com>
+From ee91df95bf010fad44be5d2564e7d40038987f19 Mon Sep 17 00:00:00 2001
+Message-Id: <ee91df95bf010fad44be5d2564e7d40038987f19.1527290717.git.jan.steffens@gmail.com>
From: Serge Hallyn <serge.hallyn@canonical.com>
Date: Fri, 31 May 2013 19:12:12 +0100
-Subject: [PATCH 1/2] add sysctl to disallow unprivileged CLONE_NEWUSER by
+Subject: [PATCH 1/3] add sysctl to disallow unprivileged CLONE_NEWUSER by
default
Signed-off-by: Serge Hallyn <serge.hallyn@ubuntu.com>
@@ -15,10 +15,10 @@ Signed-off-by: Daniel Micay <danielmicay@gmail.com>
3 files changed, 30 insertions(+)
diff --git a/kernel/fork.c b/kernel/fork.c
-index 2295fc69717f..6f320a216e7d 100644
+index e5d9d405ae4e..c4be89c51f25 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
-@@ -102,6 +102,11 @@
+@@ -103,6 +103,11 @@
#define CREATE_TRACE_POINTS
#include <trace/events/task.h>
@@ -30,7 +30,7 @@ index 2295fc69717f..6f320a216e7d 100644
/*
* Minimum number of threads to boot the kernel
-@@ -1550,6 +1555,10 @@ static __latent_entropy struct task_struct *copy_process(
+@@ -1591,6 +1596,10 @@ static __latent_entropy struct task_struct *copy_process(
if ((clone_flags & (CLONE_NEWUSER|CLONE_FS)) == (CLONE_NEWUSER|CLONE_FS))
return ERR_PTR(-EINVAL);
@@ -41,7 +41,7 @@ index 2295fc69717f..6f320a216e7d 100644
/*
* Thread groups must share signals as well, and detached threads
* can only be started up within the thread group.
-@@ -2343,6 +2352,12 @@ SYSCALL_DEFINE1(unshare, unsigned long, unshare_flags)
+@@ -2385,6 +2394,12 @@ SYSCALL_DEFINE1(unshare, unsigned long, unshare_flags)
if (unshare_flags & CLONE_NEWNS)
unshare_flags |= CLONE_FS;
@@ -55,7 +55,7 @@ index 2295fc69717f..6f320a216e7d 100644
if (err)
goto bad_unshare_out;
diff --git a/kernel/sysctl.c b/kernel/sysctl.c
-index 557d46728577..c19d7a828913 100644
+index f98f28c12020..7256d339a32a 100644
--- a/kernel/sysctl.c
+++ b/kernel/sysctl.c
@@ -105,6 +105,9 @@ extern int core_uses_pid;
@@ -68,7 +68,7 @@ index 557d46728577..c19d7a828913 100644
extern int pid_max;
extern int pid_max_min, pid_max_max;
extern int percpu_pagelist_fraction;
-@@ -513,6 +516,15 @@ static struct ctl_table kern_table[] = {
+@@ -515,6 +518,15 @@ static struct ctl_table kern_table[] = {
.proc_handler = proc_dointvec,
},
#endif
@@ -99,5 +99,5 @@ index 246d4d4ce5c7..f64432b45cec 100644
static DEFINE_MUTEX(userns_state_mutex);
--
-2.16.1
+2.17.0
diff --git a/0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch b/0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch
new file mode 100644
index 000000000000..ecd2d721d1c1
--- /dev/null
+++ b/0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch
@@ -0,0 +1,125 @@
+From f593e0bde601ff2b4f84b7363e4dfcbbda652e6d Mon Sep 17 00:00:00 2001
+Message-Id: <f593e0bde601ff2b4f84b7363e4dfcbbda652e6d.1527290717.git.jan.steffens@gmail.com>
+In-Reply-To: <ee91df95bf010fad44be5d2564e7d40038987f19.1527290717.git.jan.steffens@gmail.com>
+References: <ee91df95bf010fad44be5d2564e7d40038987f19.1527290717.git.jan.steffens@gmail.com>
+From: Mika Westerberg <mika.westerberg@linux.intel.com>
+Date: Mon, 23 Apr 2018 14:16:03 +0300
+Subject: [PATCH 2/3] ACPI / watchdog: Prefer iTCO_wdt on Lenovo Z50-70
+
+WDAT table on Lenovo Z50-70 is using RTC SRAM (ports 0x70 and 0x71) to
+store state of the timer. This conflicts with Linux RTC driver
+(rtc-cmos.c) who fails to reserve those ports for itself preventing RTC
+from functioning. In addition the WDAT table seems not to be fully
+functional because it does not reset the system when the watchdog times
+out.
+
+On this system iTCO_wdt works just fine so we simply prefer to use it
+instead of WDAT. This makes RTC working again and also results working
+watchdog via iTCO_wdt.
+
+Reported-by: Peter Milley <pbmilley@gmail.com>
+Link: https://bugzilla.kernel.org/show_bug.cgi?id=199033
+Signed-off-by: Mika Westerberg <mika.westerberg@linux.intel.com>
+Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
+---
+ drivers/acpi/acpi_watchdog.c | 59 ++++++++++++++++++++++++++++++------
+ 1 file changed, 49 insertions(+), 10 deletions(-)
+
+diff --git a/drivers/acpi/acpi_watchdog.c b/drivers/acpi/acpi_watchdog.c
+index ebb626ffb5fa..4bde16fb97d8 100644
+--- a/drivers/acpi/acpi_watchdog.c
++++ b/drivers/acpi/acpi_watchdog.c
+@@ -12,41 +12,80 @@
+ #define pr_fmt(fmt) "ACPI: watchdog: " fmt
+
+ #include <linux/acpi.h>
++#include <linux/dmi.h>
+ #include <linux/ioport.h>
+ #include <linux/platform_device.h>
+
+ #include "internal.h"
+
++static const struct dmi_system_id acpi_watchdog_skip[] = {
++ {
++ /*
++ * On Lenovo Z50-70 there are two issues with the WDAT
++ * table. First some of the instructions use RTC SRAM
++ * to store persistent information. This does not work well
++ * with Linux RTC driver. Second, more important thing is
++ * that the instructions do not actually reset the system.
++ *
++ * On this particular system iTCO_wdt seems to work just
++ * fine so we prefer that over WDAT for now.
++ *
++ * See also https://bugzilla.kernel.org/show_bug.cgi?id=199033.
++ */
++ .ident = "Lenovo Z50-70",
++ .matches = {
++ DMI_MATCH(DMI_SYS_VENDOR, "LENOVO"),
++ DMI_MATCH(DMI_PRODUCT_NAME, "20354"),
++ DMI_MATCH(DMI_PRODUCT_VERSION, "Lenovo Z50-70"),
++ },
++ },
++ {}
++};
++
++static const struct acpi_table_wdat *acpi_watchdog_get_wdat(void)
++{
++ const struct acpi_table_wdat *wdat = NULL;
++ acpi_status status;
++
++ if (acpi_disabled)
++ return NULL;
++
++ if (dmi_check_system(acpi_watchdog_skip))
++ return NULL;
++
++ status = acpi_get_table(ACPI_SIG_WDAT, 0,
++ (struct acpi_table_header **)&wdat);
++ if (ACPI_FAILURE(status)) {
++ /* It is fine if there is no WDAT */
++ return NULL;
++ }
++
++ return wdat;
++}
++
+ /**
+ * Returns true if this system should prefer ACPI based watchdog instead of
+ * the native one (which are typically the same hardware).
+ */
+ bool acpi_has_watchdog(void)
+ {
+- struct acpi_table_header hdr;
+-
+- if (acpi_disabled)
+- return false;
+-
+- return ACPI_SUCCESS(acpi_get_table_header(ACPI_SIG_WDAT, 0, &hdr));
++ return !!acpi_watchdog_get_wdat();
+ }
+ EXPORT_SYMBOL_GPL(acpi_has_watchdog);
+
+ void __init acpi_watchdog_init(void)
+ {
+ const struct acpi_wdat_entry *entries;
+ const struct acpi_table_wdat *wdat;
+ struct list_head resource_list;
+ struct resource_entry *rentry;
+ struct platform_device *pdev;
+ struct resource *resources;
+ size_t nresources = 0;
+- acpi_status status;
+ int i;
+
+- status = acpi_get_table(ACPI_SIG_WDAT, 0,
+- (struct acpi_table_header **)&wdat);
+- if (ACPI_FAILURE(status)) {
++ wdat = acpi_watchdog_get_wdat();
++ if (!wdat) {
+ /* It is fine if there is no WDAT */
+ return;
+ }
+--
+2.17.0
+
diff --git a/0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch b/0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
deleted file mode 100644
index d5b2fac689fe..000000000000
--- a/0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 7596bfa5ccb3e3a72443871a4c6d0c4f230c1cb5 Mon Sep 17 00:00:00 2001
-Message-Id: <7596bfa5ccb3e3a72443871a4c6d0c4f230c1cb5.1518653356.git.jan.steffens@gmail.com>
-In-Reply-To: <44c5097b2711429f0d49d138681f67157982e729.1518653356.git.jan.steffens@gmail.com>
-References: <44c5097b2711429f0d49d138681f67157982e729.1518653356.git.jan.steffens@gmail.com>
-From: Jim Bride <jim.bride@linux.intel.com>
-Date: Mon, 6 Nov 2017 13:38:57 -0800
-Subject: [PATCH 2/2] drm/i915/edp: Only use the alternate fixed mode if it's
- asked for
-
-In commit dc911f5bd8aa ("drm/i915/edp: Allow alternate fixed mode for
-eDP if available."), the patch allows for the use of an alternate fixed
-mode if it is available, but the patch was not ensuring that the only
-time the alternate mode is used is when it is specifically requested.
-This patch adds an additional comparison to intel_edp_compare_alt_mode
-to ensure that we only use the alternate mode if it is directly
-requested.
-
-Fixes: dc911f5bd8aac ("Allow alternate fixed mode for eDP if available.")
-Cc: David Weinehall <david.weinehall@linux.intel.com>
-Cc: Rodrigo Vivi <rodrigo.vivi@intel.com>
-Signed-off-by: Jim Bride <jim.bride@linux.intel.com>
----
- drivers/gpu/drm/i915/intel_dp.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c
-index 158438bb0389..69b16df868ea 100644
---- a/drivers/gpu/drm/i915/intel_dp.c
-+++ b/drivers/gpu/drm/i915/intel_dp.c
-@@ -1616,7 +1616,8 @@ static bool intel_edp_compare_alt_mode(struct drm_display_mode *m1,
- m1->vdisplay == m2->vdisplay &&
- m1->vsync_start == m2->vsync_start &&
- m1->vsync_end == m2->vsync_end &&
-- m1->vtotal == m2->vtotal);
-+ m1->vtotal == m2->vtotal &&
-+ m1->vrefresh == m2->vrefresh);
- return bres;
- }
-
---
-2.16.1
-
diff --git a/0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch b/0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
new file mode 100644
index 000000000000..78f97b2ddb3e
--- /dev/null
+++ b/0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
@@ -0,0 +1,242 @@
+From b7438d9dd645801027ab11470850033da0521338 Mon Sep 17 00:00:00 2001
+Message-Id: <b7438d9dd645801027ab11470850033da0521338.1527290717.git.jan.steffens@gmail.com>
+In-Reply-To: <ee91df95bf010fad44be5d2564e7d40038987f19.1527290717.git.jan.steffens@gmail.com>
+References: <ee91df95bf010fad44be5d2564e7d40038987f19.1527290717.git.jan.steffens@gmail.com>
+From: Jani Nikula <jani.nikula@intel.com>
+Date: Wed, 16 May 2018 11:01:10 +0300
+Subject: [PATCH 3/3] Revert "drm/i915/edp: Allow alternate fixed mode for eDP
+ if available."
+
+This reverts commit dc911f5bd8aacfcf8aabd5c26c88e04c837a938e.
+
+Per the report, no matter what display mode you select with xrandr, the
+i915 driver will always select the alternate fixed mode. For the
+reporter this means that the display will always run at 40Hz which is
+quite annoying. This may be due to the mode comparison.
+
+But there are some other potential issues. The choice of alt_fixed_mode
+seems dubious. It's the first non-preferred mode, but there are no
+guarantees that the only difference would be refresh rate. Similarly,
+there may be more than one preferred mode in the probed modes list, and
+the commit changes the preferred mode selection to choose the last one
+on the list instead of the first.
+
+(Note that the probed modes list is the raw, unfiltered, unsorted list
+of modes from drm_add_edid_modes(), not the pretty result after a
+drm_helper_probe_single_connector_modes() call.)
+
+Finally, we already have eerily similar code in place to find the
+downclock mode for DRRS that seems like could be reused here.
+
+Back to the drawing board.
+
+Note: This is a hand-crafted revert due to conflicts. If it fails to
+backport, please just try reverting the original commit directly.
+
+Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=105469
+Reported-by: Rune Petersen <rune@megahurts.dk>
+Reported-by: Mark Spencer <n7u4722r35@ynzlx.anonbox.net>
+Fixes: dc911f5bd8aa ("drm/i915/edp: Allow alternate fixed mode for eDP if available.")
+Cc: Clint Taylor <clinton.a.taylor@intel.com>
+Cc: David Weinehall <david.weinehall@linux.intel.com>
+Cc: Rodrigo Vivi <rodrigo.vivi@intel.com>
+Cc: Paulo Zanoni <paulo.r.zanoni@intel.com>
+Cc: Jani Nikula <jani.nikula@intel.com>
+Cc: Chris Wilson <chris@chris-wilson.co.uk>
+Cc: Jim Bride <jim.bride@linux.intel.com>
+Cc: Jani Nikula <jani.nikula@linux.intel.com>
+Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
+Cc: intel-gfx@lists.freedesktop.org
+Cc: <stable@vger.kernel.org> # v4.14+
+Signed-off-by: Jani Nikula <jani.nikula@intel.com>
+Reviewed-by: Dhinakaran Pandiyan <dhinakaran.pandiyan@intel.com>
+Link: https://patchwork.freedesktop.org/patch/msgid/20180516080110.22770-1-jani.nikula@intel.com
+---
+ drivers/gpu/drm/i915/intel_dp.c | 38 ++++--------------------------
+ drivers/gpu/drm/i915/intel_drv.h | 2 --
+ drivers/gpu/drm/i915/intel_dsi.c | 2 +-
+ drivers/gpu/drm/i915/intel_dvo.c | 2 +-
+ drivers/gpu/drm/i915/intel_lvds.c | 3 +--
+ drivers/gpu/drm/i915/intel_panel.c | 6 -----
+ 6 files changed, 8 insertions(+), 45 deletions(-)
+
+diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c
+index 79521da5d11d..de0d0f83551e 100644
+--- a/drivers/gpu/drm/i915/intel_dp.c
++++ b/drivers/gpu/drm/i915/intel_dp.c
+@@ -1584,23 +1584,6 @@ static int intel_dp_compute_bpp(struct intel_dp *intel_dp,
+ return bpp;
+ }
+
+-static bool intel_edp_compare_alt_mode(struct drm_display_mode *m1,
+- struct drm_display_mode *m2)
+-{
+- bool bres = false;
+-
+- if (m1 && m2)
+- bres = (m1->hdisplay == m2->hdisplay &&
+- m1->hsync_start == m2->hsync_start &&
+- m1->hsync_end == m2->hsync_end &&
+- m1->htotal == m2->htotal &&
+- m1->vdisplay == m2->vdisplay &&
+- m1->vsync_start == m2->vsync_start &&
+- m1->vsync_end == m2->vsync_end &&
+- m1->vtotal == m2->vtotal);
+- return bres;
+-}
+-
+ bool
+ intel_dp_compute_config(struct intel_encoder *encoder,
+ struct intel_crtc_state *pipe_config,
+@@ -1647,16 +1630,8 @@ intel_dp_compute_config(struct intel_encoder *encoder,
+ pipe_config->has_audio = intel_conn_state->force_audio == HDMI_AUDIO_ON;
+
+ if (intel_dp_is_edp(intel_dp) && intel_connector->panel.fixed_mode) {
+- struct drm_display_mode *panel_mode =
+- intel_connector->panel.alt_fixed_mode;
+- struct drm_display_mode *req_mode = &pipe_config->base.mode;
+-
+- if (!intel_edp_compare_alt_mode(req_mode, panel_mode))
+- panel_mode = intel_connector->panel.fixed_mode;
+-
+- drm_mode_debug_printmodeline(panel_mode);
+-
+- intel_fixed_panel_mode(panel_mode, adjusted_mode);
++ intel_fixed_panel_mode(intel_connector->panel.fixed_mode,
++ adjusted_mode);
+
+ if (INTEL_GEN(dev_priv) >= 9) {
+ int ret;
+@@ -5821,7 +5796,6 @@ static bool intel_edp_init_connector(struct intel_dp *intel_dp,
+ struct drm_i915_private *dev_priv = to_i915(dev);
+ struct drm_connector *connector = &intel_connector->base;
+ struct drm_display_mode *fixed_mode = NULL;
+- struct drm_display_mode *alt_fixed_mode = NULL;
+ struct drm_display_mode *downclock_mode = NULL;
+ bool has_dpcd;
+ struct drm_display_mode *scan;
+@@ -5876,14 +5850,13 @@ static bool intel_edp_init_connector(struct intel_dp *intel_dp,
+ }
+ intel_connector->edid = edid;
+
+- /* prefer fixed mode from EDID if available, save an alt mode also */
++ /* prefer fixed mode from EDID if available */
+ list_for_each_entry(scan, &connector->probed_modes, head) {
+ if ((scan->type & DRM_MODE_TYPE_PREFERRED)) {
+ fixed_mode = drm_mode_duplicate(dev, scan);
+ downclock_mode = intel_dp_drrs_init(
+ intel_connector, fixed_mode);
+- } else if (!alt_fixed_mode) {
+- alt_fixed_mode = drm_mode_duplicate(dev, scan);
++ break;
+ }
+ }
+
+@@ -5920,8 +5893,7 @@ static bool intel_edp_init_connector(struct intel_dp *intel_dp,
+ pipe_name(pipe));
+ }
+
+- intel_panel_init(&intel_connector->panel, fixed_mode, alt_fixed_mode,
+- downclock_mode);
++ intel_panel_init(&intel_connector->panel, fixed_mode, downclock_mode);
+ intel_connector->panel.backlight.power = intel_edp_backlight_power;
+ intel_panel_setup_backlight(connector, pipe);
+
+diff --git a/drivers/gpu/drm/i915/intel_drv.h b/drivers/gpu/drm/i915/intel_drv.h
+index 30f791f89d64..9b75b82a2956 100644
+--- a/drivers/gpu/drm/i915/intel_drv.h
++++ b/drivers/gpu/drm/i915/intel_drv.h
+@@ -264,7 +264,6 @@ struct intel_encoder {
+
+ struct intel_panel {
+ struct drm_display_mode *fixed_mode;
+- struct drm_display_mode *alt_fixed_mode;
+ struct drm_display_mode *downclock_mode;
+
+ /* backlight */
+@@ -1720,7 +1719,6 @@ void intel_overlay_reset(struct drm_i915_private *dev_priv);
+ /* intel_panel.c */
+ int intel_panel_init(struct intel_panel *panel,
+ struct drm_display_mode *fixed_mode,
+- struct drm_display_mode *alt_fixed_mode,
+ struct drm_display_mode *downclock_mode);
+ void intel_panel_fini(struct intel_panel *panel);
+ void intel_fixed_panel_mode(const struct drm_display_mode *fixed_mode,
+diff --git a/drivers/gpu/drm/i915/intel_dsi.c b/drivers/gpu/drm/i915/intel_dsi.c
+index f67d321376e4..551bf1c14093 100644
+--- a/drivers/gpu/drm/i915/intel_dsi.c
++++ b/drivers/gpu/drm/i915/intel_dsi.c
+@@ -1851,7 +1851,7 @@ void intel_dsi_init(struct drm_i915_private *dev_priv)
+ connector->display_info.width_mm = fixed_mode->width_mm;
+ connector->display_info.height_mm = fixed_mode->height_mm;
+
+- intel_panel_init(&intel_connector->panel, fixed_mode, NULL, NULL);
++ intel_panel_init(&intel_connector->panel, fixed_mode, NULL);
+ intel_panel_setup_backlight(connector, INVALID_PIPE);
+
+ intel_dsi_add_properties(intel_connector);
+diff --git a/drivers/gpu/drm/i915/intel_dvo.c b/drivers/gpu/drm/i915/intel_dvo.c
+index 754baa00bea9..05bd65e37cb5 100644
+--- a/drivers/gpu/drm/i915/intel_dvo.c
++++ b/drivers/gpu/drm/i915/intel_dvo.c
+@@ -537,7 +537,7 @@ void intel_dvo_init(struct drm_i915_private *dev_priv)
+ */
+ intel_panel_init(&intel_connector->panel,
+ intel_dvo_get_current_mode(intel_encoder),
+- NULL, NULL);
++ NULL);
+ intel_dvo->panel_wants_dither = true;
+ }
+
+diff --git a/drivers/gpu/drm/i915/intel_lvds.c b/drivers/gpu/drm/i915/intel_lvds.c
+index 7ed6f7b69556..ab5a63f007eb 100644
+--- a/drivers/gpu/drm/i915/intel_lvds.c
++++ b/drivers/gpu/drm/i915/intel_lvds.c
+@@ -1128,8 +1128,7 @@ void intel_lvds_init(struct drm_i915_private *dev_priv)
+ out:
+ mutex_unlock(&dev->mode_config.mutex);
+
+- intel_panel_init(&intel_connector->panel, fixed_mode, NULL,
+- downclock_mode);
++ intel_panel_init(&intel_connector->panel, fixed_mode, downclock_mode);
+ intel_panel_setup_backlight(connector, INVALID_PIPE);
+
+ lvds_encoder->is_dual_link = compute_is_dual_link_lvds(lvds_encoder);
+diff --git a/drivers/gpu/drm/i915/intel_panel.c b/drivers/gpu/drm/i915/intel_panel.c
+index fa6831f8c004..c0ac6d6bf8ef 100644
+--- a/drivers/gpu/drm/i915/intel_panel.c
++++ b/drivers/gpu/drm/i915/intel_panel.c
+@@ -1924,30 +1924,24 @@ intel_panel_init_backlight_funcs(struct intel_panel *panel)
+
+ int intel_panel_init(struct intel_panel *panel,
+ struct drm_display_mode *fixed_mode,
+- struct drm_display_mode *alt_fixed_mode,
+ struct drm_display_mode *downclock_mode)
+ {
+ intel_panel_init_backlight_funcs(panel);
+
+ panel->fixed_mode = fixed_mode;
+- panel->alt_fixed_mode = alt_fixed_mode;
+ panel->downclock_mode = downclock_mode;
+
+ return 0;
+ }
+
+ void intel_panel_fini(struct intel_panel *panel)
+ {
+ struct intel_connector *intel_connector =
+ container_of(panel, struct intel_connector, panel);
+
+ if (panel->fixed_mode)
+ drm_mode_destroy(intel_connector->base.dev, panel->fixed_mode);
+
+- if (panel->alt_fixed_mode)
+- drm_mode_destroy(intel_connector->base.dev,
+- panel->alt_fixed_mode);
+-
+ if (panel->downclock_mode)
+ drm_mode_destroy(intel_connector->base.dev,
+ panel->downclock_mode);
+--
+2.17.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 0d6ec7babaec..abc8820d33ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,7 +54,7 @@ _major=4.16
_srcname=linux-${_major}
_minor=12
pkgver=${_major}.${_minor}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/dolohow/uksm"
license=('GPL2')
@@ -88,7 +88,8 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
# standard config files for mkinitcpio ramdisk
'linux.preset'
'0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch'
- '0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch')
+ '0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch'
+ '0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-uksm}
@@ -104,9 +105,13 @@ prepare() {
msg "Disable USER_NS for non-root users by default"
patch -Np1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+ ### Fix https://bugs.archlinux.org/task/56780
+ msg "Fix #56780"
+ patch -Np1 -i ../0002-ACPI-watchdog-Prefer-iTCO_wdt-on-Lenovo-Z50-70.patch
+
### Fix https://bugs.archlinux.org/task/56711
msg "Fix #56711"
- patch -Np1 -i ../0002-drm-i915-edp-Only-use-the-alternate-fixed-mode-if-it.patch
+ patch -Np1 -i ../0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
### Fix gcc8 bogus warnings
msg "Fix gcc8 bogus warnings"
@@ -387,8 +392,9 @@ sha512sums=('ab47849314b177d0eec9dbf261f33972b0d89fb92fb0650130ffa7abc2f36c0fab2
'4a8b324aee4cccf3a512ad04ce1a272d14e5b05c8de90feb82075f55ea3845948d817e1b0c6f298f5816834ddd3e5ce0a0e2619866289f3c1ab8fd2f35f04f44'
'6346b66f54652256571ef65da8e46db49a95ac5978ecd57a507c6b2a28aee70bb3ff87045ac493f54257c9965da1046a28b72cb5abb0087204d257f14b91fd74'
'2dc6b0ba8f7dbf19d2446c5c5f1823587de89f4e28e9595937dd51a87755099656f2acec50e3e2546ea633ad1bfd1c722e0c2b91eef1d609103d8abdc0a7cbaf'
- '99c4b03829317b03839c4bcf8a5ffead5918504b95b4bf2733ca38ec5a153a03781aa4b5e6f4297cc12c1e63a07a74da04b730f107ede212fe247e658933853b'
- '7621840ad2f9760b30885b46b1b4e5b2b51d726a7ee771ce7649fb217c3af16577edb65c326b0754cf1a87b00fb981f0697ce916b3dcaf80731bc9a373aa685c')
+ '26619b938a47c841f0c480a113cfbb1ee6f1121c21dfecbe246c1f7af7697f86cfb8253f09966eab2e386734ce4ad156159babdba4365c2f199c369c3d7e8ee8'
+ 'f6aed92697c35e7919a0d784185e7af15b6be2762e3dd235267ca9744a826ac693d0ffcb07b9d1cc8571f57d518c1ce1c276cf7677e8375188f05f71d4added0'
+ 'cc8852b089aa24f588ad1af726503ecd1012ad7e1cbc47ea77f03a5f7aecd25306d40f2e16b8a1afeafe7e2e97b6b6840c9f462ed7be358090117e2e024df1bd')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds