summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31df8cf1c3bc..fc8eb6ccdce2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mullvad-vpn-cli
pkgdesc = The Mullvad VPN CLI client
- pkgver = 2023.6
+ pkgver = 2024.2
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
@@ -15,13 +15,12 @@ pkgbase = mullvad-vpn-cli
depends = libnftnl
provides = mullvad-vpn
conflicts = mullvad-vpn
- options = !lto
- source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=c2f7f75dee35c050540b90c6ebc9084969b1a93b
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2024.2
source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=d5772339cee9c1a0d7671968746f02499b78e245?signed
validpgpkeys = 225E40C8F1C8DEB7977ABF59F293063FECE2E8ED
validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
validpgpkeys = 4B986EF5222BA1B810230C602F391DE6B00D619C
- sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = b50af32532ecb05502bbd6eab4514417bd6889bbaefccc11d0f5cefbf7685d8e
+ sha256sums = 255d3b3de761215b02086184006d65bd5c6972f9e9f7364c177693d67429547f
pkgname = mullvad-vpn-cli
diff --git a/PKGBUILD b/PKGBUILD
index 92ec7e5ecff0..116c7a552340 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: John Andrews <theunderdog09 at gmail dot com>
# Contributor: Timo Kramer <fw minus aur at timokramer dot de>
pkgname=mullvad-vpn-cli
-pkgver=2023.6
+pkgver=2024.2
pkgrel=1
pkgdesc="The Mullvad VPN CLI client"
arch=('x86_64')
@@ -12,24 +12,17 @@ depends=('dbus' 'iputils' 'libnftnl')
makedepends=('cargo' 'git' 'go' 'protobuf')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-options=('!lto')
install="${pkgname%-*}.install"
-_tag=c2f7f75dee35c050540b90c6ebc9084969b1a93b # tags/2023.6^0
_commit=d5772339cee9c1a0d7671968746f02499b78e245
-source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}" # signed by Oskar Nyberg (raksooo), public key not uploaded yet
+source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=$pkgver" # signed by Oskar Nyberg (raksooo), public key not uploaded yet
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed")
-sha256sums=('SKIP'
- 'SKIP')
+sha256sums=('b50af32532ecb05502bbd6eab4514417bd6889bbaefccc11d0f5cefbf7685d8e'
+ '255d3b3de761215b02086184006d65bd5c6972f9e9f7364c177693d67429547f')
validpgpkeys=('225E40C8F1C8DEB7977ABF59F293063FECE2E8ED' # Linus Färnstrand <linus@mullvad.net>
'8339C7D2942EB854E3F27CE5AEE9DECFD582E984' # David Lönnhager (code signing) <david.l@mullvad.net>
'4B986EF5222BA1B810230C602F391DE6B00D619C' # Oskar Nyberg (code signing) <oskar@mullvad.net>
)
-pkgver() {
- cd "$srcdir/mullvadvpn-app"
- git describe --tags | sed 's/-/./g'
-}
-
prepare() {
cd mullvadvpn-app
git submodule init
@@ -49,6 +42,7 @@ prepare() {
build() {
cd mullvadvpn-app
+ CFLAGS+=" -ffat-lto-objects"
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target