summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
l---------.gitignore1
-rw-r--r--PKGBUILD25
3 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be9993ebce4e..c08cb5b15952 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 21 08:23:39 UTC 2018
+# Thu May 9 11:51:37 UTC 2019
pkgbase = ncmpc-git
pkgdesc = A fully featured MPD client, which runs in a terminal (using ncurses).
- pkgver = 0.29.283.g8bb65be
+ pkgver = 0.34.1.g93dcece
pkgrel = 1
url = http://www.musicpd.org/clients/ncmpc/
arch = i686
diff --git a/.gitignore b/.gitignore
new file mode 120000
index 000000000000..25c0564928e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/home/aksr/arch/pkg/.gitignore \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 1edce407c475..43c7bafdad33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Contributor: Rasi <rasi@xssn.at>
# Maintainer: aksr <aksr at t-com dot me>
pkgname=ncmpc-git
-pkgver=0.29.283.g8bb65be
+pkgver=0.34.1.g93dcece
pkgrel=1
-pkgdesc="A fully featured MPD client, which runs in a terminal (using ncurses)."
+pkgdesc="A fully featured MPD client, which runs in a terminal (using ncurses)."
arch=('i686' 'x86_64')
url="http://www.musicpd.org/clients/ncmpc/"
license=('GPL')
@@ -18,23 +18,24 @@ pkgver() {
git describe --always | sed 's/^v//g;s|-|.|g'
}
-prepare() {
- cd "$srcdir/$pkgname"
- sed -i 's!ncursesw/curses.h!curses.h!g' meson.build
- sed -i 's!ncursesw/curses.h!curses.h!g' src/ncmpc_curses.h
-}
-
build() {
cd "$srcdir/$pkgname"
meson --prefix /usr . output
- meson configure -Dartist_screen=true \
+ meson configure -Dasync_connect=true \
-Dchat_screen=true \
- -Dcolors=auto \
+ -Dcolors=false \
-Dhelp_screen=true \
-Dkey_screen=true \
+ -Dlibrary_screen=true \
+ -Dlirc=auto \
+ -Dlocale=auto \
-Dlyrics_screen=true \
- -Dmouse=true \
+ -Dmanual=true \
+ -Dmouse=enabled \
+ -Dmultibyte=true \
+ -Dnls=auto \
-Doutputs_screen=true \
+ -Dregex=enabled \
-Dsearch_screen=true \
-Dsong_screen=true output
}
@@ -44,5 +45,5 @@ package() {
DESTDIR=$pkgdir ninja -C output install
rm $pkgdir/usr/share/doc/${pkgname%-*}/{AUTHORS,COPYING,NEWS}
install -Dm644 COPYING $pkgdir/usr/share/licenses/${pkgname%-*}/COPYING
-}
+}