summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1edce407c475..43c7bafdad33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Contributor: Rasi <rasi@xssn.at>
# Maintainer: aksr <aksr at t-com dot me>
pkgname=ncmpc-git
-pkgver=0.29.283.g8bb65be
+pkgver=0.34.1.g93dcece
pkgrel=1
-pkgdesc="A fully featured MPD client, which runs in a terminal (using ncurses)."
+pkgdesc="A fully featured MPD client, which runs in a terminal (using ncurses)."
arch=('i686' 'x86_64')
url="http://www.musicpd.org/clients/ncmpc/"
license=('GPL')
@@ -18,23 +18,24 @@ pkgver() {
git describe --always | sed 's/^v//g;s|-|.|g'
}
-prepare() {
- cd "$srcdir/$pkgname"
- sed -i 's!ncursesw/curses.h!curses.h!g' meson.build
- sed -i 's!ncursesw/curses.h!curses.h!g' src/ncmpc_curses.h
-}
-
build() {
cd "$srcdir/$pkgname"
meson --prefix /usr . output
- meson configure -Dartist_screen=true \
+ meson configure -Dasync_connect=true \
-Dchat_screen=true \
- -Dcolors=auto \
+ -Dcolors=false \
-Dhelp_screen=true \
-Dkey_screen=true \
+ -Dlibrary_screen=true \
+ -Dlirc=auto \
+ -Dlocale=auto \
-Dlyrics_screen=true \
- -Dmouse=true \
+ -Dmanual=true \
+ -Dmouse=enabled \
+ -Dmultibyte=true \
+ -Dnls=auto \
-Doutputs_screen=true \
+ -Dregex=enabled \
-Dsearch_screen=true \
-Dsong_screen=true output
}
@@ -44,5 +45,5 @@ package() {
DESTDIR=$pkgdir ninja -C output install
rm $pkgdir/usr/share/doc/${pkgname%-*}/{AUTHORS,COPYING,NEWS}
install -Dm644 COPYING $pkgdir/usr/share/licenses/${pkgname%-*}/COPYING
-}
+}