summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ab18e6b63d1..8e34315c0bc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = neovim-git
pkgdesc = Fork of Vim aiming to improve user experience, plugins, and GUIs.
- pkgver = 0.r4069.cd6b4af
+ pkgver = 0.r4306.68e5968
pkgrel = 1
- url = http://neovim.io
+ url = https://neovim.io
install = neovim-git.install
arch = i686
arch = x86_64
@@ -22,7 +22,7 @@ pkgbase = neovim-git
optdepends = python-neovim: for Python 3 plugin support (see :help nvim-python)
optdepends = xclip: for clipboard support (or xsel) (see :help nvim-clipboard)
optdepends = xsel: for clipboard support (or xclip) (see :help nvim-clipboard)
- provides = neovim=0.r4069.cd6b4af
+ provides = neovim=0.r4306.68e5968
conflicts = neovim
source = neovim-git::git+https://github.com/neovim/neovim.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 331377c61a36..f8c32a133c4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
# Contributor: Florian Hahn <flo@fhahn.com>
pkgname=neovim-git
-pkgver=0.r4069.cd6b4af
+pkgver=0.r4306.68e5968
pkgrel=1
pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs.'
arch=('i686' 'x86_64')
-url='http://neovim.io'
+url='https://neovim.io'
license=('custom:neovim')
depends=('jemalloc' 'libtermkey' 'libuv' 'libvterm-bzr' 'msgpack-c' 'unibilium')
makedepends=('cmake' 'git' 'luajit' 'lua51-messagepack' 'lua51-lpeg')
@@ -28,8 +28,11 @@ pkgver() {
build() {
mkdir -p "${pkgname}/build"
cd "${pkgname}/build"
- cmake -G 'Unix Makefiles' -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -G 'Unix Makefiles' \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_JEMALLOC=ON \
+ ..
make
}