summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--nvm.install22
3 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5f4a12b499f..363e11c349ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nvm
- pkgdesc = Simple bash script to manage multiple active node.js versions
+ pkgdesc = Node Version Manager - Simple bash script to manage multiple active node.js versions
pkgver = 0.29.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/creationix/nvm
install = nvm.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 5a04ceae3a98..69ad3c15e0c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=nvm
pkgver=0.29.0
-pkgrel=1
-pkgdesc="Simple bash script to manage multiple active node.js versions"
+pkgrel=2
+pkgdesc="Node Version Manager - Simple bash script to manage multiple active node.js versions"
url="https://github.com/creationix/nvm"
arch=('any')
license=('MIT')
@@ -26,7 +26,7 @@ package() {
cd "${pkgname}-${pkgver}"
- # nvm.sh
+ # nvm itself
install -Dm644 nvm.sh "$pkgdir/usr/share/$pkgname/nvm.sh"
# bash completion
diff --git a/nvm.install b/nvm.install
index 88a452e767b7..b9b188a7cb03 100644
--- a/nvm.install
+++ b/nvm.install
@@ -2,20 +2,26 @@
post_install() {
echo "
You need to source nvm before you can use it. Do one of the following
-or similar depending on your shell:
+or similar depending on your shell (and then restart your shell):
echo 'source /usr/share/nvm/init-nvm.sh' >> ~/.bashrc
echo 'source /usr/share/nvm/init-nvm.sh' >> ~/.zprofile
-Alternatively, you can copy the contents of init-nvm.sh to your
-.bashrc (or similar) if you would like an NVM_DIR other than ~/.nvm
+You can now install node.js versions (e.g. nvm install 5.0) and
+activate them (e.g. nvm use 5.0). You may want to activate your
+preferred node.js version in your .bashrc (or similar) after
+sourcing init-nvm.sh.
+
+init-nvm.sh is a convenience script which does the following:
"
-}
+ cat usr/share/nvm/init-nvm.sh
+ echo "
+You may wish to customize and put these lines directly in your
+.bashrc (or similar) if, for example, you would like an NVM_DIR
+other than ~/.nvm or you don't want bash completion.
-## arg 1: the new package version
-## arg 2: the old package version
-post_upgrade() {
- post_install
+See the nvm readme for more information: https://github.com/creationix/nvm
+"
}
## arg 1: the old package version