summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 036508a08002..37a53d3c2bd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ompl
pkgdesc = The Open Motion Planning Library (OMPL) consists of many state-of-the-art sampling-based motion planning algorithms
- pkgver = 1.5.2
+ pkgver = 1.6.0
pkgrel = 1
url = http://ompl.kavrakilab.org/
arch = i686
@@ -26,7 +26,7 @@ pkgbase = ompl
optdepends = pygccxml: Python bindings
conflicts = ompl-git
replaces = ompl-git
- source = https://github.com/ompl/ompl/archive/1.5.2.tar.gz
- sha512sums = 5b29a409822efaf783a9076e4c2a84731956e84669ccc1d07765198b0f9812573014a8fa85e76de5cbee48385c5c588da6aba40f27b57aa9eb353b95745d9edb
+ source = https://github.com/ompl/ompl/archive/1.6.0.tar.gz
+ sha512sums = d1024d7cc8e309a1df94a950be67eefae1e66abaccd6b6b8980939559aee3d73c05c838ab24c818b6b57ce6c4b3181fde7595d3d1dd36d6cd0c6d125338084ac
pkgname = ompl
diff --git a/PKGBUILD b/PKGBUILD
index f47767f65174..c11549b33b41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Wil Thomason <wbthomason@cs.cornell.edu>
-# Former maintainer: Sven Schneider <archlinux.sandmann@googlemail.com>
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+# Contributor: Wil Thomason <wbthomason@cs.cornell.edu>
+# Contributor: Sven Schneider <archlinux.sandmann@googlemail.com>
pkgname=ompl
-pkgver=1.5.2
+pkgver=1.6.0
pkgrel=1
pkgdesc="The Open Motion Planning Library (OMPL) consists of many state-of-the-art sampling-based motion planning algorithms"
arch=('i686' 'x86_64')
@@ -25,7 +26,7 @@ optdepends=('python: Python bindings'
'castxml: Python bindings'
'pygccxml: Python bindings')
source=(https://github.com/ompl/ompl/archive/${pkgver}.tar.gz)
-sha512sums=(5b29a409822efaf783a9076e4c2a84731956e84669ccc1d07765198b0f9812573014a8fa85e76de5cbee48385c5c588da6aba40f27b57aa9eb353b95745d9edb)
+sha512sums=(d1024d7cc8e309a1df94a950be67eefae1e66abaccd6b6b8980939559aee3d73c05c838ab24c818b6b57ce6c4b3181fde7595d3d1dd36d6cd0c6d125338084ac)
build() {
# NOTE: To get Python bindings, you currently need to install pyplusplus through pip3. The AUR
@@ -40,6 +41,7 @@ build() {
cmake -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_EXE_LINKER_FLAGS="-llz4" \
-DOMPL_REGISTRATION=Off ..
cmake --build .
}